summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmmutex01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-13 15:23:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-13 15:23:25 +0000
commit02a7789c7756f84a61efe4d4fd4d0159febc2a49 (patch)
tree0868dadc8f68efcf60dea84cb2967823523b8aa9 /testsuites/psxtmtests/psxtmmutex01/Makefile.am
parent2011-07-12 Joel Sherrill <joel.sherrilL@OARcorp.com> (diff)
downloadrtems-02a7789c7756f84a61efe4d4fd4d0159febc2a49.tar.bz2
2011-07-13 Ricardo Aguirre <el.mastin@ymail.com>
PR 1831/tests * Makefile.am, configure.ac, psxtmtests_plan.csv: Add benchmark of mutex init and destroy. * psxtmmutex01/.cvsignore, psxtmmutex01/Makefile.am, psxtmmutex01/init.c, psxtmmutex01/psxtmmutex01.doc: New files.
Diffstat (limited to 'testsuites/psxtmtests/psxtmmutex01/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmmutex01/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmmutex01/Makefile.am b/testsuites/psxtmtests/psxtmmutex01/Makefile.am
new file mode 100644
index 0000000000..2ec2bfd6ad
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmmutex01/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmmutex01
+psxtmmutex01_SOURCES = init.c ../../tmtests/include/timesys.h \
+ ../../support/src/tmtests_empty_function.c \
+ ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmmutex01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmmutex01_OBJECTS) $(psxtmmutex01_LDADD)
+LINK_LIBS = $(psxtmmutex01_LDLIBS)
+
+psxtmmutex01$(EXEEXT): $(psxtmmutex01_OBJECTS) $(psxtmmutex01_DEPENDENCIES)
+ @rm -f psxtmmutex01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am