summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmmq01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-08-24 21:15:58 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-08-24 21:15:58 +0000
commitf9c237019711e0da777e7acfef0dc6ee643c782a (patch)
tree8ee228fa77ce23c64d828c4a4a0a68d801f43af3 /testsuites/psxtmtests/psxtmmq01/Makefile.am
parent2011-08-24 Sebastian Huber <sebastian.huber@embedded-brains.de> (diff)
downloadrtems-f9c237019711e0da777e7acfef0dc6ee643c782a.tar.bz2
2011-08-24 Ricardo Aguirre <el.mastin@ymail.com>
PR 1903/testing * Makefile.am, configure.ac, psxtmtests_plan.csv: Add test for message queues which covers most open, close, unlink cases as well as send/receive which do not involve task state changes. * psxtmmq01/.cvsignore, psxtmmq01/Makefile.am, psxtmmq01/init.c, psxtmmq01/psxtmmq01.doc: New files.
Diffstat (limited to 'testsuites/psxtmtests/psxtmmq01/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmmq01/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmmq01/Makefile.am b/testsuites/psxtmtests/psxtmmq01/Makefile.am
new file mode 100644
index 0000000000..b81e9ddcdd
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmmq01/Makefile.am
@@ -0,0 +1,31 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmmq01
+psxtmmq01_SOURCES = init.c
+psxtmmq01_SOURCES += ../../tmtests/include/timesys.h
+psxtmmq01_SOURCES += ../../support/src/tmtests_empty_function.c
+psxtmmq01_SOURCES += ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmmq01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmmq01_OBJECTS) $(psxtmmq01_LDADD)
+LINK_LIBS = $(psxtmmq01_LDLIBS)
+
+psxtmmq01$(EXEEXT): $(psxtmmq01_OBJECTS) $(psxtmmq01_DEPENDENCIES)
+ @rm -f psxtmmq01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am