summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmkey01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-20 13:20:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-20 13:20:25 +0000
commit7be58fc5615b8a29ca51011904a231a1e1452a8e (patch)
tree896d7ec0552747426d8a9d7dad14dbd12dba9433 /testsuites/psxtmtests/psxtmkey01/Makefile.am
parentRegenerate. (diff)
downloadrtems-7be58fc5615b8a29ca51011904a231a1e1452a8e.tar.bz2
2011-07-20 Ricardo Aguirre <el.mastin@ymail.com>
PR 1843/tests * Makefile.am, configure.ac, psxtmtests_plan.csv: Add benchmark of key create and delete. * psxtmkey01/.cvsignore, psxtmkey01/Makefile.am, psxtmkey01/init.c, psxtmkey01/psxtmkey01.doc: New files.
Diffstat (limited to 'testsuites/psxtmtests/psxtmkey01/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmkey01/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmkey01/Makefile.am b/testsuites/psxtmtests/psxtmkey01/Makefile.am
new file mode 100644
index 0000000000..290b76c74c
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmkey01/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmkey01
+psxtmkey01_SOURCES = init.c ../../tmtests/include/timesys.h \
+ ../../support/src/tmtests_empty_function.c \
+ ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmkey01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmkey01_OBJECTS) $(psxtmkey01_LDADD)
+LINK_LIBS = $(psxtmkey01_LDLIBS)
+
+psxtmkey01$(EXEEXT): $(psxtmkey01_OBJECTS) $(psxtmkey01_DEPENDENCIES)
+ @rm -f psxtmkey01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am