summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmcond04/Makefile.am
diff options
context:
space:
mode:
authorDaniel Ramirez <javamonn@gmail.com>2013-11-30 20:27:44 -0600
committerGedare Bloom <gedare@rtems.org>2013-11-30 21:31:30 -0500
commit72ff7569b096457332cd8de7fe0f00c16b87fb1b (patch)
tree19e10619f87748ee153e3b38e00ad1d7c253144c /testsuites/psxtmtests/psxtmcond04/Makefile.am
parentpsx07.doc: New file (diff)
downloadrtems-72ff7569b096457332cd8de7fe0f00c16b87fb1b.tar.bz2
psxtmtests: added new psxtmcond04 test, fixed psxtmcond03
Diffstat (limited to 'testsuites/psxtmtests/psxtmcond04/Makefile.am')
-rw-r--r--testsuites/psxtmtests/psxtmcond04/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmcond04/Makefile.am b/testsuites/psxtmtests/psxtmcond04/Makefile.am
new file mode 100644
index 0000000000..875b08c576
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmcond04/Makefile.am
@@ -0,0 +1,27 @@
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmcond04
+psxtmcond04_SOURCES = init.c
+psxtmcond04_SOURCES += ../../tmtests/include/timesys.h
+psxtmcond04_SOURCES += ../../support/src/tmtests_empty_function.c
+psxtmcond04_SOURCES += ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmcond04.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmcond04_OBJECTS) $(psxtmcond04_LDADD)
+LINK_LIBS = $(psxtmcond04_LDLIBS)
+
+psxtmcond04$(EXEEXT): $(psxtmcond04_OBJECTS) $(psxtmcond04_DEPENDENCIES)
+ @rm -f psxtmcond04$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am