summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-11-17 22:39:05 +0530
committerJoel Sherrill <joel@rtems.org>2018-11-17 12:56:35 -0600
commitedd366c9ef8ae72e037927257b0e02d2c9625c69 (patch)
tree9761f0fbd9084b4067f0fce40ef3f79f122474cf /testsuites/psxtmtests/Makefile.am
parentpsxtmtests_plan.csv: Update to reflect psxtmmqrcvblock01 (GCI 2018) (diff)
downloadrtems-edd366c9ef8ae72e037927257b0e02d2c9625c69.tar.bz2
psxtmcleanup01: new POSIX timing suite (GCI 2018)
Diffstat (limited to 'testsuites/psxtmtests/Makefile.am')
-rw-r--r--testsuites/psxtmtests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/Makefile.am b/testsuites/psxtmtests/Makefile.am
index 2ef514d665..1101a5b447 100644
--- a/testsuites/psxtmtests/Makefile.am
+++ b/testsuites/psxtmtests/Makefile.am
@@ -57,6 +57,18 @@ psxtmbarrier04_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmbarrier04) \
-DOPERATION_COUNT=$(OPERATION_COUNT)
endif
+if TEST_psxtmcleanup01
+psxtm_tests += psxtmcleanup01
+psxtm_docs += psxtmcleanup01/psxtmcleanup01.doc
+psxtmcleanup01_SOURCES = psxtmcleanup01/init.c \
+ ../tmtests/include/timesys.h ../support/src/tmtests_empty_function.c \
+ ../support/src/tmtests_support.c
+psxtmcleanup01_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(TEST_FLAGS_psxtmcleanup01) $(support_includes) \
+ -I$(top_srcdir)/../tmtests/include \
+ -DOPERATION_COUNT=$(OPERATION_COUNT)
+endif
+
if TEST_psxtmclocknanosleep01
psxtm_tests += psxtmclocknanosleep01
psxtm_docs += psxtmclocknanosleep01/psxtmclocknanosleep01.doc