summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-11-20 06:41:58 +0530
committerJoel Sherrill <joel@rtems.org>2018-11-20 09:26:57 -0600
commitedae517758338c5d6103cde6ca1ad85d1bf551fd (patch)
tree666c9eda442913c54e3815bb2bea4d369696c7ef /testsuites/psxtmtests/Makefile.am
parentbsps/moxie: Use interrupt stack for init stack (diff)
downloadrtems-edae517758338c5d6103cde6ca1ad85d1bf551fd.tar.bz2
psxtmutexattr01: Added new POSIX timing suite (GCI 2018)
Diffstat (limited to 'testsuites/psxtmtests/Makefile.am')
-rw-r--r--testsuites/psxtmtests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/Makefile.am b/testsuites/psxtmtests/Makefile.am
index 1101a5b447..920ff6e081 100644
--- a/testsuites/psxtmtests/Makefile.am
+++ b/testsuites/psxtmtests/Makefile.am
@@ -326,6 +326,17 @@ psxtmmutex07_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmmutex07) \
-DOPERATION_COUNT=$(OPERATION_COUNT)
endif
+if TEST_psxtmmutexattr01
+psxtm_tests += psxtmmutexattr01
+psxtm_docs += psxtmmutexattr01/psxtmmutexattr01.doc
+psxtmmutexattr01_SOURCES = psxtmmutexattr01/init.c \
+ ../tmtests/include/timesys.h ../support/src/tmtests_empty_function.c \
+ ../support/src/tmtests_support.c
+psxtmmutexattr01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmmutexattr01) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include \
+ -DOPERATION_COUNT=$(OPERATION_COUNT)
+endif
+
if TEST_psxtmnanosleep01
psxtm_tests += psxtmnanosleep01
psxtm_docs += psxtmnanosleep01/psxtmnanosleep01.doc