summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-11-15 11:48:48 +0530
committerJoel Sherrill <joel@rtems.org>2018-11-15 14:00:59 -0600
commit8abb230b775f9cd2ac571fca6964d3ad249cba70 (patch)
tree23ff7a1215b4506244dc66d2d3915a7a2ded473c /testsuites/psxtmtests/Makefile.am
parenttestsuites/psxtests/psxhdrs: Fix comment so copyright block is separate (diff)
downloadrtems-8abb230b775f9cd2ac571fca6964d3ad249cba70.tar.bz2
psxtmthreadattr01: Add new test (GCI 2018)
Diffstat (limited to 'testsuites/psxtmtests/Makefile.am')
-rw-r--r--testsuites/psxtmtests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/Makefile.am b/testsuites/psxtmtests/Makefile.am
index 1607ac6adf..ae2af47a82 100644
--- a/testsuites/psxtmtests/Makefile.am
+++ b/testsuites/psxtmtests/Makefile.am
@@ -569,6 +569,17 @@ psxtmthread06_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmthread06) \
-DOPERATION_COUNT=$(OPERATION_COUNT)
endif
+if TEST_psxtmthreadattr01
+psxtm_tests += psxtmthreadattr01
+psxtm_docs += psxtmthreadattr01/psxtmthreadattr01.doc
+psxtmthreadattr01_SOURCES = psxtmthreadattr01/init.c \
+ ../tmtests/include/timesys.h ../support/src/tmtests_empty_function.c \
+ ../support/src/tmtests_support.c
+psxtmthreadattr01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmthreadattr01) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include \
+ -DOPERATION_COUNT=$(OPERATION_COUNT)
+endif
+
rtems_tests_PROGRAMS = $(psxtm_tests)
dist_rtems_tests_DATA = $(psxtm_screens) $(psxtm_docs)