summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-11-21 21:30:35 +0530
committerJoel Sherrill <joel@rtems.org>2018-11-21 14:12:54 -0600
commit69812aaa2cee4123546af55510a8d6737cd11b07 (patch)
tree34164df84773b3aded6a4ef22db97ef6573df0a9 /testsuites/psxtmtests/Makefile.am
parentscore: Simplify _Workspace_String_duplicate() (diff)
downloadrtems-69812aaa2cee4123546af55510a8d6737cd11b07.tar.bz2
psxtmbarrierattr01: Added new POSIX timing suite (GCI 2018)
Diffstat (limited to 'testsuites/psxtmtests/Makefile.am')
-rw-r--r--testsuites/psxtmtests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/Makefile.am b/testsuites/psxtmtests/Makefile.am
index 920ff6e081..d87921d133 100644
--- a/testsuites/psxtmtests/Makefile.am
+++ b/testsuites/psxtmtests/Makefile.am
@@ -57,6 +57,17 @@ psxtmbarrier04_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmbarrier04) \
-DOPERATION_COUNT=$(OPERATION_COUNT)
endif
+if TEST_psxtmbarrierattr01
+psxtm_tests += psxtmbarrierattr01
+psxtm_docs += psxtmbarrierattr01/psxtmbarrierattr01.doc
+psxtmbarrierattr01_SOURCES = psxtmbarrierattr01/init.c \
+ ../tmtests/include/timesys.h ../support/src/tmtests_empty_function.c \
+ ../support/src/tmtests_support.c
+psxtmbarrierattr01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxtmbarrierattr01) \
+ $(support_includes) -I$(top_srcdir)/../tmtests/include \
+ -DOPERATION_COUNT=$(OPERATION_COUNT)
+endif
+
if TEST_psxtmcleanup01
psxtm_tests += psxtmcleanup01
psxtm_docs += psxtmcleanup01/psxtmcleanup01.doc