summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxtimes01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-06 01:01:42 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-06 01:01:42 +0000
commit85c8e754f1c220091783982890da9585d22f8dc3 (patch)
treea04306b0665ccc08d2b6d38989db7f2fa5a2353c /testsuites/psxtests/psxtimes01/Makefile.am
parent2010-07-05 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-85c8e754f1c220091783982890da9585d22f8dc3.tar.bz2
2010-07-05 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add test for various forms of times() and getrusage(). * psxgetrusage01/.cvsignore, psxgetrusage01/Makefile.am, psxgetrusage01/init.c, psxgetrusage01/psxgetrusage01.doc, psxgetrusage01/psxgetrusage01.scn, psxtimes01/.cvsignore, psxtimes01/Makefile.am, psxtimes01/init.c, psxtimes01/psxtimes01.doc, psxtimes01/psxtimes01.scn: New files.
Diffstat (limited to 'testsuites/psxtests/psxtimes01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxtimes01/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxtimes01/Makefile.am b/testsuites/psxtests/psxtimes01/Makefile.am
new file mode 100644
index 0000000000..f5d362dead
--- /dev/null
+++ b/testsuites/psxtests/psxtimes01/Makefile.am
@@ -0,0 +1,24 @@
+##
+## $Id$
+##
+
+rtems_tests_PROGRAMS = psxtimes01
+psxtimes01_SOURCES = init.c ../../support/src/spin.c
+
+dist_rtems_tests_DATA = psxtimes01.scn
+dist_rtems_tests_DATA += psxtimes01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtimes01_OBJECTS) $(psxtimes01_LDADD)
+LINK_LIBS = $(psxtimes01_LDLIBS)
+
+psxtimes01$(EXEEXT): $(psxtimes01_OBJECTS) $(psxtimes01_DEPENDENCIES)
+ @rm -f psxtimes01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am