summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxspin02/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-20 01:12:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-20 01:12:25 +0000
commit1938cc07dfb66d4192083ad0c91a9ae57c3b4a6c (patch)
treee65f002c53708aa203ef85c140eb5f5bacee9aef /testsuites/psxtests/psxspin02/Makefile.am
parent2009-07-19 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-1938cc07dfb66d4192083ad0c91a9ae57c3b4a6c.tar.bz2
2009-07-19 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add psxspin02 to exercise case where trylock is unable to obtain the spinlock and that attempting to unlock a spinlock from a thread which did not lock it works as expected. * psxspin02/.cvsignore, psxspin02/Makefile.am, psxspin02/main.c, psxspin02/psxspin02.doc, psxspin02/psxspin02.scn, psxspin02/test.c: New files.
Diffstat (limited to 'testsuites/psxtests/psxspin02/Makefile.am')
-rw-r--r--testsuites/psxtests/psxspin02/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxspin02/Makefile.am b/testsuites/psxtests/psxspin02/Makefile.am
new file mode 100644
index 0000000000..4eeae611d5
--- /dev/null
+++ b/testsuites/psxtests/psxspin02/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxspin02
+psxspin02_SOURCES = main.c test.c ../include/pmacros.h
+
+scndir = $(rtems_testsdir)
+dist_scn_DATA = psxspin02.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxspin02_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxspin02_OBJECTS) $(psxspin02_LDADD)
+LINK_LIBS = $(psxspin02_LDLIBS)
+
+psxspin02$(EXEEXT): $(psxspin02_OBJECTS) \
+ $(psxspin02_DEPENDENCIES)
+ @rm -f psxspin02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am