summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxsignal05/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-05 18:13:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-05 18:13:29 +0000
commitb053cab093896ec765294a3ed109670f94063036 (patch)
tree82a19ef7eb7ac7bff15959397191fc25c27a3a25 /testsuites/psxtests/psxsignal05/Makefile.am
parent2009-08-05 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-b053cab093896ec765294a3ed109670f94063036.tar.bz2
2009-08-05 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add a test to exercise an odd case in _POSIX_signals_Clear_signals. * psxsignal05/.cvsignore, psxsignal05/Makefile.am, psxsignal05/init.c, psxsignal05/psxsignal05.doc, psxsignal05/psxsignal05.scn: New files.
Diffstat (limited to 'testsuites/psxtests/psxsignal05/Makefile.am')
-rw-r--r--testsuites/psxtests/psxsignal05/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxsignal05/Makefile.am b/testsuites/psxtests/psxsignal05/Makefile.am
new file mode 100644
index 0000000000..9c04045670
--- /dev/null
+++ b/testsuites/psxtests/psxsignal05/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxsignal05
+psxsignal05_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxsignal05.scn
+dist_rtems_tests_DATA += psxsignal05.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxsignal05_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxsignal05_OBJECTS) $(psxsignal05_LDADD)
+LINK_LIBS = $(psxsignal05_LDLIBS)
+
+psxsignal05$(EXEEXT): $(psxsignal05_OBJECTS) $(psxsignal05_DEPENDENCIES)
+ @rm -f psxsignal05$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am