summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxonce01/Makefile.am
diff options
context:
space:
mode:
authorChristian Mauderer <Christian.Mauderer@embedded-brains.de>2014-03-18 16:25:33 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-03-19 08:34:27 +0100
commit6592cabade83930ae03f086afd416a9bcd029197 (patch)
treee289b022f1f8375d0c4a4c64f2c5bbf6912a2c68 /testsuites/psxtests/psxonce01/Makefile.am
parentscore: Add _Assert_Not_reached() (diff)
downloadrtems-6592cabade83930ae03f086afd416a9bcd029197.tar.bz2
psxtests: move pthread_once tests into an extra test.
Diffstat (limited to 'testsuites/psxtests/psxonce01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxonce01/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxonce01/Makefile.am b/testsuites/psxtests/psxonce01/Makefile.am
new file mode 100644
index 0000000000..bb11fe178b
--- /dev/null
+++ b/testsuites/psxtests/psxonce01/Makefile.am
@@ -0,0 +1,22 @@
+
+rtems_tests_PROGRAMS = psxonce01
+psxonce01_SOURCES = init.c system.h ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxonce01.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxonce01_OBJECTS)
+LINK_LIBS = $(psxonce01_LDLIBS)
+
+psxonce01$(EXEEXT): $(psxonce01_OBJECTS) $(psxonce01_DEPENDENCIES)
+ @rm -f psxonce01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am