summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxmsgq04/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-29 20:15:33 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-29 20:15:33 +0000
commit330e858cc23e3ef43836a5015ce64fd9d42db3b1 (patch)
treea8beb7273ea08163455b0756438609429ec4daa7 /testsuites/psxtests/psxmsgq04/Makefile.am
parent2009-07-29 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-330e858cc23e3ef43836a5015ce64fd9d42db3b1.tar.bz2
2009-07-29 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add shell of new test. * psxmsgq04/.cvsignore, psxmsgq04/Makefile.am, psxmsgq04/init.c, psxmsgq04/psxmsgq04.doc, psxmsgq04/psxmsgq04.scn: New files.
Diffstat (limited to 'testsuites/psxtests/psxmsgq04/Makefile.am')
-rw-r--r--testsuites/psxtests/psxmsgq04/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxmsgq04/Makefile.am b/testsuites/psxtests/psxmsgq04/Makefile.am
new file mode 100644
index 0000000000..ada73d494b
--- /dev/null
+++ b/testsuites/psxtests/psxmsgq04/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxmsgq04
+psxmsgq04_SOURCES = init.c ../include/pmacros.h \
+ ../../support/src/test_support.c
+
+dist_rtems_tests_DATA = psxmsgq04.scn
+dist_rtems_tests_DATA += psxmsgq04.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxmsgq04_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxmsgq04_OBJECTS) $(psxmsgq04_LDADD)
+LINK_LIBS = $(psxmsgq04_LDLIBS)
+
+psxmsgq04$(EXEEXT): $(psxmsgq04_OBJECTS) $(psxmsgq04_DEPENDENCIES)
+ @rm -f psxmsgq04$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am