summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxmmap01/Makefile.am
diff options
context:
space:
mode:
authorKevin Kirspel <kevin-kirspel@idexx.com>2017-06-29 10:36:44 -0400
committerGedare Bloom <gedare@rtems.org>2017-07-14 16:04:05 -0400
commit1549beb15b8b3d96179ca7d1f95ae845b0462e82 (patch)
treee0cf6b3b87118d62178572b2ad4f62fd60e03dd0 /testsuites/psxtests/psxmmap01/Makefile.am
parentposix/mmap: Add support for file handler and MAP_ANON (diff)
downloadrtems-1549beb15b8b3d96179ca7d1f95ae845b0462e82.tar.bz2
psxtests: Add a mmap dedicated test case
Updates #2859
Diffstat (limited to 'testsuites/psxtests/psxmmap01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxmmap01/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxmmap01/Makefile.am b/testsuites/psxtests/psxmmap01/Makefile.am
new file mode 100644
index 0000000000..57b008719e
--- /dev/null
+++ b/testsuites/psxtests/psxmmap01/Makefile.am
@@ -0,0 +1,22 @@
+
+rtems_tests_PROGRAMS = psxmmap01
+psxmmap01_SOURCES = init.c test_helper.c test_driver.c system.h
+
+dist_rtems_tests_DATA = psxmmap01.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxmmap01_OBJECTS)
+LINK_LIBS = $(psxmmap01_LDLIBS)
+
+psxmmap01$(EXEEXT): $(psxmmap01_OBJECTS) $(psxmmap01_DEPENDENCIES)
+ @rm -f psxmmap01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am