summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxhdrs/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2015-02-11 13:59:29 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2015-02-12 15:30:44 -0600
commitb57a6a711adb5f6afe6aee57ecc211fd746ea5ab (patch)
tree2a85a8537c8948067fe22c76ef7310373c9cd446 /testsuites/psxtests/psxhdrs/Makefile.am
parentpsxhdrs: Remove test of pthread_attr_[gs]et_cputime (diff)
downloadrtems-b57a6a711adb5f6afe6aee57ecc211fd746ea5ab.tar.bz2
psxhdrs: Reorganize into subdirectories per .h file and rename files
This is a better organization and makes it clearer which file is testing which method from which header file.
Diffstat (limited to 'testsuites/psxtests/psxhdrs/Makefile.am')
-rw-r--r--testsuites/psxtests/psxhdrs/Makefile.am158
1 files changed, 136 insertions, 22 deletions
diff --git a/testsuites/psxtests/psxhdrs/Makefile.am b/testsuites/psxtests/psxhdrs/Makefile.am
index 6b0d5d658d..0888e24aaf 100644
--- a/testsuites/psxtests/psxhdrs/Makefile.am
+++ b/testsuites/psxtests/psxhdrs/Makefile.am
@@ -1,26 +1,140 @@
noinst_LIBRARIES = lib.a
-lib_a_SOURCES = clock01.c clock02.c clock03.c clock04.c clock05.c clock06.c \
- cond01.c cond02.c cond03.c cond04.c cond05.c cond06.c cond07.c cond08.c \
- cond09.c cond10.c key01.c key02.c key03.c key04.c mutex01.c mutex02.c \
- mutex03.c mutex04.c mutex05.c mutex06.c mutex07.c mutex08.c mutex09.c \
- mutex10.c mutex11.c mutex12.c mutex13.c mutex14.c mutex15.c mutex16.c \
- pthread01.c pthread02.c pthread03.c pthread04.c pthread05.c pthread06.c \
- pthread07.c pthread08.c pthread09.c pthread10.c pthread11.c pthread12.c \
- pthread13.c pthread14.c pthread15.c pthread16.c pthread17.c pthread18.c \
- pthread19.c pthread20.c pthread21.c pthread22.c pthread23.c pthread24.c \
- pthread25.c pthread26.c pthread27.c pthread28.c pthread29.c pthread30.c \
- pthread31.c pthread32.c pthread34.c \
- pthread37.c pthread38.c pthread39.c pthread40.c \
- proc01.c proc02.c proc03.c proc04.c proc05.c proc06.c proc07.c proc08.c \
- proc09.c proc10.c proc11.c proc12.c proc13.c proc14.c sched01.c \
- sched02.c sched03.c sched04.c sched05.c sched06.c sched07.c sched08.c \
- signal01.c signal02.c signal03.c signal04.c signal05.c signal06.c \
- signal07.c signal08.c signal09.c signal10.c signal11.c signal12.c \
- signal13.c signal14.c signal15.c signal16.c signal17.c signal18.c \
- signal19.c signal20.c signal21.c signal22.c signal23.c sync01.c sync02.c \
- sync03.c time01.c time02.c time03.c time04.c time05.c time06.c time07.c \
- time08.c time09.c time10.c time11.c time12.c time13.c timer01.c \
- timer02.c timer03.c timer04.c timer05.c timer06.c timer07.c
+lib_a_SOURCES =
+
+# methods in <pthread.h>
+lib_a_SOURCES += pthread/pthread_attr_destroy.c
+lib_a_SOURCES += pthread/pthread_attr_getdetachstate.c
+lib_a_SOURCES += pthread/pthread_attr_getguardsize.c
+lib_a_SOURCES += pthread/pthread_attr_getinheritsched.c
+lib_a_SOURCES += pthread/pthread_attr_getschedparam.c
+lib_a_SOURCES += pthread/pthread_attr_getschedpolicy.c
+lib_a_SOURCES += pthread/pthread_attr_getscope.c
+lib_a_SOURCES += pthread/pthread_attr_getstackaddr.c
+lib_a_SOURCES += pthread/pthread_attr_getstack.c
+lib_a_SOURCES += pthread/pthread_attr_getstacksize.c
+lib_a_SOURCES += pthread/pthread_attr_init.c
+lib_a_SOURCES += pthread/pthread_attr_setdetachstate.c
+lib_a_SOURCES += pthread/pthread_attr_setguardsize.c
+lib_a_SOURCES += pthread/pthread_attr_setinheritsched.c
+lib_a_SOURCES += pthread/pthread_attr_setschedparam.c
+lib_a_SOURCES += pthread/pthread_attr_setschedpolicy.c
+lib_a_SOURCES += pthread/pthread_attr_setscope.c
+lib_a_SOURCES += pthread/pthread_attr_setstackaddr.c
+lib_a_SOURCES += pthread/pthread_attr_setstack.c
+lib_a_SOURCES += pthread/pthread_attr_setstacksize.c
+lib_a_SOURCES += pthread/pthread_cancel.c
+lib_a_SOURCES += pthread/pthread_cleanup.c
+lib_a_SOURCES += pthread/pthread_condattr_destroy.c
+lib_a_SOURCES += pthread/pthread_condattr_getpshared.c
+lib_a_SOURCES += pthread/pthread_condattr_init.c
+lib_a_SOURCES += pthread/pthread_condattr_setpshared.c
+lib_a_SOURCES += pthread/pthread_cond_broadcast.c
+lib_a_SOURCES += pthread/pthread_cond_destroy.c
+lib_a_SOURCES += pthread/pthread_cond_init.c
+lib_a_SOURCES += pthread/pthread_cond_signal.c
+lib_a_SOURCES += pthread/pthread_cond_timedwait.c
+lib_a_SOURCES += pthread/pthread_cond_wait.c
+lib_a_SOURCES += pthread/pthread_create.c
+lib_a_SOURCES += pthread/pthread_detach.c
+lib_a_SOURCES += pthread/pthread_equal.c
+lib_a_SOURCES += pthread/pthread_exit.c
+lib_a_SOURCES += pthread/pthread_getcpuclockid.c
+lib_a_SOURCES += pthread/pthread_getschedparam.c
+lib_a_SOURCES += pthread/pthread_getspecific.c
+lib_a_SOURCES += pthread/pthread_join.c
+lib_a_SOURCES += pthread/pthread_key_create.c
+lib_a_SOURCES += pthread/pthread_key_delete.c
+lib_a_SOURCES += pthread/pthread_mutexattr_destroy.c
+lib_a_SOURCES += pthread/pthread_mutexattr_getprioceiling.c
+lib_a_SOURCES += pthread/pthread_mutexattr_getprotocol.c
+lib_a_SOURCES += pthread/pthread_mutexattr_getpshared.c
+lib_a_SOURCES += pthread/pthread_mutexattr_init.c
+lib_a_SOURCES += pthread/pthread_mutexattr_setprioceiling.c
+lib_a_SOURCES += pthread/pthread_mutexattr_setprotocol.c
+lib_a_SOURCES += pthread/pthread_mutexattr_setpshared.c
+lib_a_SOURCES += pthread/pthread_mutex_destroy.c
+lib_a_SOURCES += pthread/pthread_mutex_getprioceiling.c
+lib_a_SOURCES += pthread/pthread_mutex_init.c
+lib_a_SOURCES += pthread/pthread_mutex_lock.c
+lib_a_SOURCES += pthread/pthread_mutex_setprioceiling.c
+lib_a_SOURCES += pthread/pthread_mutex_timedlock.c
+lib_a_SOURCES += pthread/pthread_mutex_trylock.c
+lib_a_SOURCES += pthread/pthread_mutex_unlock.c
+lib_a_SOURCES += pthread/pthread_once.c
+lib_a_SOURCES += pthread/pthread_self.c
+lib_a_SOURCES += pthread/pthread_setcancelstate.c
+lib_a_SOURCES += pthread/pthread_setcanceltype.c
+lib_a_SOURCES += pthread/pthread_setschedparam.c
+lib_a_SOURCES += pthread/pthread_setspecific.c
+lib_a_SOURCES += pthread/pthread_testcancel.c
+# methods in <sched.h>
+lib_a_SOURCES += sched/sched_getparam.c
+lib_a_SOURCES += sched/sched_get_priority_max.c
+lib_a_SOURCES += sched/sched_get_priority_min.c
+lib_a_SOURCES += sched/sched_getscheduler.c
+lib_a_SOURCES += sched/sched_rr_get_interval.c
+lib_a_SOURCES += sched/sched_setparam.c
+lib_a_SOURCES += sched/sched_setscheduler.c
+lib_a_SOURCES += sched/sched_yield.c
+# methods in <signal.h>
+lib_a_SOURCES += signal/pthread_sigmask.c
+lib_a_SOURCES += signal/raise.c
+lib_a_SOURCES += signal/signal.c
+lib_a_SOURCES += signal/sigpending.c
+lib_a_SOURCES += signal/sigprocmask.c
+lib_a_SOURCES += signal/sigsuspend.c
+lib_a_SOURCES += signal/sigtimedwait.c
+lib_a_SOURCES += signal/sigwait.c
+lib_a_SOURCES += signal/sigwaitinfo.c
+# methods in <time.h>
+lib_a_SOURCES += time/asctime.c
+lib_a_SOURCES += time/asctime_r.c
+lib_a_SOURCES += time/clock.c
+lib_a_SOURCES += time/clock_getcpuclockid.c
+lib_a_SOURCES += time/clock_getenable_attr.c
+lib_a_SOURCES += time/clock_getres.c
+lib_a_SOURCES += time/clock_gettime.c
+lib_a_SOURCES += time/clock_setenable_attr.c
+lib_a_SOURCES += time/clock_settime.c
+lib_a_SOURCES += time/ctime.c
+lib_a_SOURCES += time/ctime_r.c
+lib_a_SOURCES += time/difftime.c
+lib_a_SOURCES += time/gmtime.c
+lib_a_SOURCES += time/gmtime_r.c
+lib_a_SOURCES += time/localtime.c
+lib_a_SOURCES += time/localtime_r.c
+lib_a_SOURCES += time/mktime.c
+lib_a_SOURCES += time/nanosleep.c
+lib_a_SOURCES += time/strftime.c
+lib_a_SOURCES += time/time.c
+lib_a_SOURCES += time/timer_create.c
+lib_a_SOURCES += time/timer_delete.c
+lib_a_SOURCES += time/timer_getoverrun.c
+lib_a_SOURCES += time/timer_gettime.c
+lib_a_SOURCES += time/timer_settime.c
+# methods in <unistd.h>
+lib_a_SOURCES += unistd/alarm.c
+lib_a_SOURCES += unistd/fdatasync.c
+lib_a_SOURCES += unistd/fsync.c
+lib_a_SOURCES += unistd/getegid.c
+lib_a_SOURCES += unistd/geteuid.c
+lib_a_SOURCES += unistd/getgid.c
+lib_a_SOURCES += unistd/getgroups.c
+lib_a_SOURCES += unistd/getlogin.c
+lib_a_SOURCES += unistd/getlogin_r.c
+lib_a_SOURCES += unistd/getpgrp.c
+lib_a_SOURCES += unistd/getpid.c
+lib_a_SOURCES += unistd/getppid.c
+lib_a_SOURCES += unistd/getuid.c
+lib_a_SOURCES += unistd/pause.c
+lib_a_SOURCES += unistd/setgid.c
+lib_a_SOURCES += unistd/setpgid.c
+lib_a_SOURCES += unistd/setsid.c
+lib_a_SOURCES += unistd/setuid.c
+lib_a_SOURCES += unistd/sleep.c
+lib_a_SOURCES += unistd/sync.c
+lib_a_SOURCES += unistd/ualarm.c
+lib_a_SOURCES += unistd/usleep.c
if HAS_NETWORKING
# methods in <sys/socket.h>