summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxhdrs/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-02-19 16:00:48 -0600
committerJoel Sherrill <joel@rtems.org>2016-04-14 16:28:10 -0500
commit8228548d127dd73439615f45f38f92b8a42bcfed (patch)
treeb7a48c833e30bcbd736f649815129c8aff2201f4 /testsuites/psxtests/psxhdrs/Makefile.am
parentposix: Run key destructors during thread restart (diff)
downloadrtems-8228548d127dd73439615f45f38f92b8a42bcfed.tar.bz2
Add pthread_getconcurrency() and pthread_setconcurrency()
This is the very simple implementation specified by the Open Group for implementations with 1:1 kernel thread to user thread mappings. http://pubs.opengroup.org/onlinepubs/9699919799/functions/pthread_getconcurrency.html updates #2680.
Diffstat (limited to 'testsuites/psxtests/psxhdrs/Makefile.am')
-rw-r--r--testsuites/psxtests/psxhdrs/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxhdrs/Makefile.am b/testsuites/psxtests/psxhdrs/Makefile.am
index 8dc13e17cf..3eecd84dbd 100644
--- a/testsuites/psxtests/psxhdrs/Makefile.am
+++ b/testsuites/psxtests/psxhdrs/Makefile.am
@@ -38,6 +38,7 @@ lib_a_SOURCES += pthread/pthread_create.c
lib_a_SOURCES += pthread/pthread_detach.c
lib_a_SOURCES += pthread/pthread_equal.c
lib_a_SOURCES += pthread/pthread_exit.c
+lib_a_SOURCES += pthread/pthread_getconcurrency.c
lib_a_SOURCES += pthread/pthread_getcpuclockid.c
lib_a_SOURCES += pthread/pthread_getschedparam.c
lib_a_SOURCES += pthread/pthread_getspecific.c
@@ -64,6 +65,7 @@ lib_a_SOURCES += pthread/pthread_once.c
lib_a_SOURCES += pthread/pthread_self.c
lib_a_SOURCES += pthread/pthread_setcancelstate.c
lib_a_SOURCES += pthread/pthread_setcanceltype.c
+lib_a_SOURCES += pthread/pthread_setconcurrency.c
lib_a_SOURCES += pthread/pthread_setschedparam.c
lib_a_SOURCES += pthread/pthread_setspecific.c
lib_a_SOURCES += pthread/pthread_testcancel.c