summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxfile02/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <Jennifer.Averett@OARcorp.com>2010-06-23 18:43:24 +0000
committerJennifer Averett <Jennifer.Averett@OARcorp.com>2010-06-23 18:43:24 +0000
commit6cb72216e7bbf070c498a7a65272d0b546e45f8a (patch)
treeb55876cbfd1075d19a64b3fb433e143038dcb46b /testsuites/psxtests/psxfile02/Makefile.am
parent2010-06-23 Joel Sherrill <joel.sherrilL@OARcorp.com> (diff)
downloadrtems-6cb72216e7bbf070c498a7a65272d0b546e45f8a.tar.bz2
2010-06-23 Jennifer Averett <Jennifer Averett@OARcorp.com>
* Makefile.am, configure.ac: Added test case for calls that check for an unopened file descriptor. * psxfile02/.cvsignore, psxfile02/Makefile.am, psxfile02/init.c, psxfile02/psxfile02.doc, psxfile02/psxfile02.scn: New files.
Diffstat (limited to 'testsuites/psxtests/psxfile02/Makefile.am')
-rw-r--r--testsuites/psxtests/psxfile02/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxfile02/Makefile.am b/testsuites/psxtests/psxfile02/Makefile.am
new file mode 100644
index 0000000000..73f82c01ab
--- /dev/null
+++ b/testsuites/psxtests/psxfile02/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxfile02
+psxfile02_SOURCES = init.c ../../support/src/spin.c
+
+dist_rtems_tests_DATA = psxfile02.scn
+dist_rtems_tests_DATA += psxfile02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxfile02_OBJECTS) $(psxfile02_LDADD)
+LINK_LIBS = $(psxfile02_LDLIBS)
+
+psxfile02$(EXEEXT): $(psxfile02_OBJECTS) $(psxfile02_DEPENDENCIES)
+ @rm -f psxfile02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am