summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxdevctl01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-12-05 21:06:40 -0600
committerJoel Sherrill <joel@rtems.org>2017-01-11 09:45:32 -0600
commitef362818dff3e7dc437d90133424e9c9f0608a02 (patch)
treec6800ad8c9bcd8d9a894c48ea533c38d9eb3a962 /testsuites/psxtests/psxdevctl01/Makefile.am
parentposix: Fix alarm() in SMP configurations (diff)
downloadrtems-ef362818dff3e7dc437d90133424e9c9f0608a02.tar.bz2
Add support for posix_devctl()
Diffstat (limited to 'testsuites/psxtests/psxdevctl01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxdevctl01/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxdevctl01/Makefile.am b/testsuites/psxtests/psxdevctl01/Makefile.am
new file mode 100644
index 0000000000..3bc9bdc988
--- /dev/null
+++ b/testsuites/psxtests/psxdevctl01/Makefile.am
@@ -0,0 +1,23 @@
+
+rtems_tests_PROGRAMS = psxdevctl01
+psxdevctl01_SOURCES = main.c test.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxdevctl01.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxdevctl01_OBJECTS)
+LINK_LIBS = $(psxdevctl01_LDLIBS)
+
+psxdevctl01$(EXEEXT): $(psxdevctl01_OBJECTS) \
+ $(psxdevctl01_DEPENDENCIES)
+ @rm -f psxdevctl01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am