summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxcond02/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-03-09 15:15:37 -0600
committerJoel Sherrill <joel@rtems.org>2016-06-16 09:04:11 -0500
commit6131b849081335e101f92b4a99e01572153d44f5 (patch)
tree453f987a20252c55b7084e030508a8a02d1f348a /testsuites/psxtests/psxcond02/Makefile.am
parentmptests/mp03/task1.c: Make method static to fix warning (diff)
downloadrtems-6131b849081335e101f92b4a99e01572153d44f5.tar.bz2
Add pthread_condattr_getclock() and pthread_condattr_setclock()
updates #2608.
Diffstat (limited to 'testsuites/psxtests/psxcond02/Makefile.am')
-rw-r--r--testsuites/psxtests/psxcond02/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxcond02/Makefile.am b/testsuites/psxtests/psxcond02/Makefile.am
new file mode 100644
index 0000000000..82aa29c20e
--- /dev/null
+++ b/testsuites/psxtests/psxcond02/Makefile.am
@@ -0,0 +1,24 @@
+
+rtems_tests_PROGRAMS = psxcond02
+psxcond02_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxcond02.scn
+dist_rtems_tests_DATA += psxcond02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxcond02_OBJECTS)
+LINK_LIBS = $(psxcond02_LDLIBS)
+
+psxcond02$(EXEEXT): $(psxcond02_OBJECTS) \
+ $(psxcond02_DEPENDENCIES)
+ @rm -f psxcond02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am