summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxclassic01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-03-08 22:10:39 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-03-08 22:10:39 +0000
commit408eea8879966e73a382b53428961d60dd99cb86 (patch)
tree7a99b24f8a2003e0e2d21cca9c32adc5abcc3900 /testsuites/psxtests/psxclassic01/Makefile.am
parent2011-03-08 Joel Sherrill <joel.sherrilL@OARcorp.com> (diff)
downloadrtems-408eea8879966e73a382b53428961d60dd99cb86.tar.bz2
2011-03-08 Joel Sherrill <joel.sherrilL@OARcorp.com>
PR 1759/cpukit * Makefile.am, configure.ac: Add test to use some pthread calls with Classic Tasks. * psxclassic01/.cvsignore, psxclassic01/Makefile.am, psxclassic01/init.c, psxclassic01/psxclassic01.doc, psxclassic01/psxclassic01.scn: New files.
Diffstat (limited to 'testsuites/psxtests/psxclassic01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxclassic01/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxclassic01/Makefile.am b/testsuites/psxtests/psxclassic01/Makefile.am
new file mode 100644
index 0000000000..7ec0c05de9
--- /dev/null
+++ b/testsuites/psxtests/psxclassic01/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxclassic01
+psxclassic01_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxclassic01.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxclassic01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxclassic01_OBJECTS) $(psxclassic01_LDADD)
+LINK_LIBS = $(psxclassic01_LDLIBS)
+
+psxclassic01$(EXEEXT): $(psxclassic01_OBJECTS) $(psxclassic01_DEPENDENCIES)
+ @rm -f psxclassic01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am