summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxautoinit01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-07 14:30:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-07 14:30:12 +0000
commit9a845e175b55bc764cf84f11a2cc77aea7234fcb (patch)
tree210c074b6ed2ec277628f425f828121a7aeaf609 /testsuites/psxtests/psxautoinit01/Makefile.am
parent2009-07-06 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-9a845e175b55bc764cf84f11a2cc77aea7234fcb.tar.bz2
2009-07-07 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add test of pthread mutex auto intialization. * psxautoinit01/.cvsignore, psxautoinit01/Makefile.am, psxautoinit01/init.c, psxautoinit01/psxautoinit01.scn: New files.
Diffstat (limited to 'testsuites/psxtests/psxautoinit01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxautoinit01/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxautoinit01/Makefile.am b/testsuites/psxtests/psxautoinit01/Makefile.am
new file mode 100644
index 0000000000..169999c157
--- /dev/null
+++ b/testsuites/psxtests/psxautoinit01/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxautoinit01
+psxautoinit01_SOURCES = init.c ../include/pmacros.h
+
+scndir = $(rtems_testsdir)
+dist_scn_DATA = psxautoinit01.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxautoinit01_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxautoinit01_OBJECTS) $(psxautoinit01_LDADD)
+LINK_LIBS = $(psxautoinit01_LDLIBS)
+
+psxautoinit01$(EXEEXT): $(psxautoinit01_OBJECTS) \
+ $(psxautoinit01_DEPENDENCIES)
+ @rm -f psxautoinit01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am