summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxaio02/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2010-08-16 13:29:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2010-08-16 13:29:49 +0000
commitdb8c6d6492545eab85f8b6e25b57ed85c7e06371 (patch)
tree1516402f6e57312e93ad968488a483a4a751502e /testsuites/psxtests/psxaio02/Makefile.am
parent2010-08-16 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-db8c6d6492545eab85f8b6e25b57ed85c7e06371.tar.bz2
2010-08-16 Alin Rus <alin.codejunkie@gmail.com>
* Makefile.am, configure.ac: Add psxaio01/, psxaio02/. * psxaio01/Makefile.am, psxaio01/init.c, psxaio01/psxaio01.scn, psxaio01/system.h: New. * psxaio02/Makefile.am, psxaio02/init.c, psxaio02/psxaio02.scn, psxaio02/system.h: New.
Diffstat (limited to 'testsuites/psxtests/psxaio02/Makefile.am')
-rw-r--r--testsuites/psxtests/psxaio02/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxaio02/Makefile.am b/testsuites/psxtests/psxaio02/Makefile.am
new file mode 100644
index 0000000000..db1b8d4642
--- /dev/null
+++ b/testsuites/psxtests/psxaio02/Makefile.am
@@ -0,0 +1,25 @@
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxaio02
+psxaio02_SOURCES = init.c system.h ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxaio02.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxaio02_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxaio02_OBJECTS) $(psxaio02_LDADD)
+LINK_LIBS = $(psxaio02_LDLIBS)
+
+psxaio02$(EXEEXT): $(psxaio02_OBJECTS) $(psxaio02_DEPENDENCIES)
+ @rm -f psxaio02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am \ No newline at end of file