summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psx14/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-31 16:07:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-01-31 16:07:12 +0000
commitc87593f0b01781996c466e340871f91d87a3d9d8 (patch)
tree46c78551dc2bb5dbb73a3bd92a62f1125358d56e /testsuites/psxtests/psx14/Makefile.am
parent2008-01-31 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-c87593f0b01781996c466e340871f91d87a3d9d8.tar.bz2
2008-01-31 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add psx14 to exercise POSIX API specific portions of Object Services added to API. * psx14/.cvsignore, psx14/Makefile.am, psx14/init.c, psx14/psx14.scn, psx14/system.h: New files.
Diffstat (limited to 'testsuites/psxtests/psx14/Makefile.am')
-rw-r--r--testsuites/psxtests/psx14/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/psxtests/psx14/Makefile.am b/testsuites/psxtests/psx14/Makefile.am
new file mode 100644
index 0000000000..e90eb2e1a1
--- /dev/null
+++ b/testsuites/psxtests/psx14/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psx14.exe
+psx14_exe_SOURCES = init.c system.h ../include/pmacros.h
+
+dist_rtems_tests_DATA = psx14.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psx14_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psx14_exe_OBJECTS) $(psx14_exe_LDADD)
+LINK_LIBS = $(psx14_exe_LDLIBS)
+
+psx14.exe$(EXEEXT): $(psx14_exe_OBJECTS) $(psx14_exe_DEPENDENCIES)
+ @rm -f psx14.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am