summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2009-10-26 04:58:07 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2009-10-26 04:58:07 +0000
commitf2ced5d99f4ff30a209dd7614882d46fcad20291 (patch)
tree3c8e2fe69fa62df1cf367f0a5040dc21f833301b /testsuites/psxtests/configure.ac
parent2009-10-26 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-f2ced5d99f4ff30a209dd7614882d46fcad20291.tar.bz2
2009-10-26 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Add AC_CHECK_HEADERS sys/mman.h. Add AC_CHECK_DECLS pthread_atfork, adjtime, mprotect.
Diffstat (limited to 'testsuites/psxtests/configure.ac')
-rw-r--r--testsuites/psxtests/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index 3849690f7c..c88c105c6b 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -27,9 +27,24 @@ AM_CONDITIONAL([HAS_NETWORKING],[test "$HAS_NETWORKING" = "yes"])
RTEMS_CHECK_CPUOPTS([RTEMS_POSIX_API])
AM_CONDITIONAL(HAS_POSIX,test x"${rtems_cv_RTEMS_POSIX_API}" = x"yes")
+# FIXME: IEEE Std 1003.1-2008 mandates sys/mman.h,
+# but newlib doesn't have sys/mman.h
+AC_CHECK_HEADERS([sys/mman.h])
+
# FIXME: newlib should supply declaration of pthread_rwlock_unlock()
AC_CHECK_DECLS([pthread_rwlock_unlock],[],[],[[#include <pthread.h>]])
+# FIXME: newlib should supply declaration of pthread_atfork()
+AC_CHECK_DECLS([pthread_atfork],[],[],[[#include <pthread.h>]])
+
+# FIXME: adjtime is a non-standardized BSD/Linux extension
+# RTEMS should not rely on adjtime
+AC_CHECK_DECLS([adjtime],[],[],[[#include <sys/time.h>]])
+
+# FIXME: IEEE Std 1003.1-2008 mandates mprotect in sys/mman.h,
+# RTEMS provides a stub, despite newlib doesn't have sys/mman.h
+AC_CHECK_DECLS([mprotect],[],[],[[#include <sys/mman.h>]])
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
psx01/Makefile