summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2009-10-25 06:51:02 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2009-10-25 06:51:02 +0000
commitcd06fd586e9faade668ae03af69c6ffc966a63f9 (patch)
tree3d9478913a1624b06fe981954ded560ce52c6d16 /testsuites/psxtests/configure.ac
parent2009-10-25 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-cd06fd586e9faade668ae03af69c6ffc966a63f9.tar.bz2
2009-10-25 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Check for pthread_rwlock_unlock in pthread.h. * psxrwlock01/test.c: Conditionally add local prototype for pthread_rwlock_unlock() if pthread.h doesn't supply it.
Diffstat (limited to 'testsuites/psxtests/configure.ac')
-rw-r--r--testsuites/psxtests/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index efe85f289f..3849690f7c 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -27,6 +27,9 @@ AM_CONDITIONAL([HAS_NETWORKING],[test "$HAS_NETWORKING" = "yes"])
RTEMS_CHECK_CPUOPTS([RTEMS_POSIX_API])
AM_CONDITIONAL(HAS_POSIX,test x"${rtems_cv_RTEMS_POSIX_API}" = x"yes")
+# FIXME: newlib should supply declaration of pthread_rwlock_unlock()
+AC_CHECK_DECLS([pthread_rwlock_unlock],[],[],[[#include <pthread.h>]])
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
psx01/Makefile