summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-13 20:36:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-13 20:36:36 +0000
commit88271c3308aef5db023687bf32ea30c60becc080 (patch)
treefd443cbf2d3209e8a1499c516773eb317a29624b /testsuites/psxtests/configure.ac
parent2009-09-13 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-88271c3308aef5db023687bf32ea30c60becc080.tar.bz2
2009-09-13 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, psx01/init.c, psx01/psx01.scn: Add new test to exercise clock and delay services enabled when POSIX threads are disabled. This is split from psx01. POSIX test suite now enabled when POSIX threads are disabled so only enable tests which are appropriate. * psxclock/.cvsignore, psxclock/Makefile.am, psxclock/init.c, psxclock/psxclock.doc, psxclock/psxclock.scn: New files.
Diffstat (limited to 'testsuites/psxtests/configure.ac')
-rw-r--r--testsuites/psxtests/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index b29992d2d7..8ce7d1fc8e 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -24,6 +24,9 @@ RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
AM_CONDITIONAL([HAS_NETWORKING],[test "$HAS_NETWORKING" = "yes"])
+RTEMS_CHECK_CPUOPTS([RTEMS_POSIX_API])
+AM_CONDITIONAL(HAS_POSIX,test x"${rtems_cv_RTEMS_POSIX_API}" = x"yes")
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
psx01/Makefile
@@ -46,6 +49,7 @@ psxbarrier01/Makefile
psxcancel/Makefile
psxchroot01/Makefile
psxcleanup/Makefile
+psxclock/Makefile
psxcond01/Makefile
psxenosys/Makefile
psxfatal01/Makefile