summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-28 23:10:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-28 23:10:15 +0000
commitbfd225e917517a10dc697f15d5fb216c386433f4 (patch)
tree20ec20068e10775f65935b0f9412a936c9501a36 /testsuites/psxtests/Makefile.am
parent2009-09-28 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-bfd225e917517a10dc697f15d5fb216c386433f4.tar.bz2
2009-09-28 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add new test for calling pthread_cancel() from an ISR. * psxcancel01/.cvsignore, psxcancel01/Makefile.am, psxcancel01/init.c, psxcancel01/psxcancel01.doc, psxcancel01/psxcancel01.scn: New files.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 388df43c27..6a934bcae0 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -8,11 +8,11 @@ SUBDIRS = psxclock
if HAS_POSIX
SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psx10 psx11 psx12 psx13 psx14 psxautoinit01 psxautoinit02 psxbarrier01 \
- psxcancel psxcleanup psxcond01 psxenosys psxkey01 psxkey02 psxkey03 \
- psxitimer psxmsgq01 psxmsgq02 psxmsgq03 psxmsgq04 psxmutexattr01 psxobj01 \
- psxrwlock01 psxsem01 psxsignal01 psxsignal02 psxsignal03 psxsignal04 \
- psxsignal05 psxspin01 psxspin02 psxsysconf psxtime psxtimer01 psxtimer02 \
- psxualarm psxfatal01 psxfatal02 \
+ psxcancel psxcancel01 psxcleanup psxcond01 psxenosys psxkey01 psxkey02 \
+ psxkey03 psxitimer psxmsgq01 psxmsgq02 psxmsgq03 psxmsgq04 \
+ psxmutexattr01 psxobj01 psxrwlock01 psxsem01 psxsignal01 psxsignal02 \
+ psxsignal03 psxsignal04 psxsignal05 psxspin01 psxspin02 psxsysconf \
+ psxtime psxtimer01 psxtimer02 psxualarm psxfatal01 psxfatal02 \
psxintrcritical01 psxstack01
endif