summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-31 22:40:31 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-07-31 22:40:31 +0000
commitbd1505b218400655a45dc278bb2afe85d86d8c57 (patch)
treeac6e20bfc11c91f3d7c43ed6ed96740181ac89fd /testsuites/psxtests/Makefile.am
parent2011-07-31 Joel Sherrill <joel.sherrilL@OARcorp.com> (diff)
downloadrtems-bd1505b218400655a45dc278bb2afe85d86d8c57.tar.bz2
2011-07-31 Joel Sherrill <joel.sherrilL@OARcorp.com>
PR 1855/cpukit * Makefile.am, configure.ac: Correct signal processing during pthread_join. We are supposed to unblock the thread waiting on a pthread_join(), dispatch the signal handler, account for it potentially overwriting errno, and then have the thread return to blocking within pthread_join(). * psxeintr_join/.cvsignore, psxeintr_join/Makefile.am, psxeintr_join/init.c, psxeintr_join/psxeintr_join.doc, psxeintr_join/psxeintr_join.scn: New files.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 977b7515f2..c987169726 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -17,7 +17,8 @@ SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psxsignal03 psxsignal04 psxsignal05 psxsignal06 \
psxspin01 psxspin02 psxsysconf \
psxtime psxtimer01 psxtimer02 psxualarm psxusleep psxfatal01 psxfatal02 \
- psxintrcritical01 psxstack01 psxstack02
+ psxintrcritical01 psxstack01 psxstack02 \
+ psxeintr_join
endif
## File IO tests