summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-12-09 17:50:13 +0530
committerJoel Sherrill <joel@rtems.org>2018-12-09 09:17:08 -0600
commitb009cfb6382bddd86440ce56c8206efb4540ec28 (patch)
tree3b05440cac079bbb5e67ebe44d46adacebfd02fa /testsuites/psxtests/Makefile.am
parentpsxhdrs: Add POSIX API Signature Compliance Tests for stdlib.h (GCI 2018) (diff)
downloadrtems-b009cfb6382bddd86440ce56c8206efb4540ec28.tar.bz2
psxhdrs: Added POSIX API Signature Compliance Tests for threads.h (GCI 2018)
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 13ac889b36..01fd04a52e 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1614,6 +1614,31 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/syslog/openlog.c \
psxhdrs/syslog/setlogmask.c \
psxhdrs/syslog/syslog.c \
+ psxhdrs/c11/threads/call_once.c \
+ psxhdrs/c11/threads/cnd_broadcast.c \
+ psxhdrs/c11/threads/cnd_destroy.c \
+ psxhdrs/c11/threads/cnd_init.c \
+ psxhdrs/c11/threads/cnd_signal.c \
+ psxhdrs/c11/threads/cnd_timedwait.c \
+ psxhdrs/c11/threads/cnd_wait.c \
+ psxhdrs/c11/threads/mtx_init.c \
+ psxhdrs/c11/threads/mtx_destroy.c \
+ psxhdrs/c11/threads/mtx_lock.c \
+ psxhdrs/c11/threads/mtx_timedlock.c \
+ psxhdrs/c11/threads/mtx_trylock.c \
+ psxhdrs/c11/threads/mtx_unlock.c \
+ psxhdrs/c11/threads/thrd_create.c \
+ psxhdrs/c11/threads/thrd_current.c \
+ psxhdrs/c11/threads/thrd_detach.c \
+ psxhdrs/c11/threads/thrd_equal.c \
+ psxhdrs/c11/threads/thrd_exit.c \
+ psxhdrs/c11/threads/thrd_join.c \
+ psxhdrs/c11/threads/thrd_sleep.c \
+ psxhdrs/c11/threads/thrd_yield.c \
+ psxhdrs/c11/threads/tss_create.c \
+ psxhdrs/c11/threads/tss_delete.c \
+ psxhdrs/c11/threads/tss_get.c \
+ psxhdrs/c11/threads/tss_set.c \
psxhdrs/wchar/btowc.c \
psxhdrs/wchar/fgetwc.c \
psxhdrs/wchar/fgetws.c \