summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorEshan dhawan <eshandhawan51@gmail.com>2021-02-04 03:04:16 +0530
committerJoel Sherrill <joel@rtems.org>2021-03-11 11:40:13 -0600
commita26a326e55922f3d52639d361e49c3ed0c3834c0 (patch)
treec829ed12c91f696675744e4746e356815e2bdaad /testsuites/psxtests/Makefile.am
parentleon,tn-0018: work around GRLIB-TN-0018 errata (diff)
downloadrtems-a26a326e55922f3d52639d361e49c3ed0c3834c0.tar.bz2
Test suite for FTW.H methods
Signed-off-by: Eshan Dhawan <eshandhawan51@gmail.com>
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rwxr-xr-xtestsuites/psxtests/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index d89bcd8801..a35f00b665 100755
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -453,6 +453,32 @@ psxfilelock01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxfilelock01) \
$(support_includes)
endif
+if TEST_psxftw01
+psx_tests += psxftw01
+psx_screens += psxftw01/psxftw01.scn
+psx_docs += psxftw01/psxftw01.doc
+psxftw01_SOURCES = psxftw01/init.c psxfile01/test_cat.c \
+ psxftw01-tar.c psxftw01-tar.h psxftw01-tar-gz.c psxftw01-tar-gz.h
+
+psxftw01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxftw01) \
+ $(support_includes) $(test_includes) -I$(top_srcdir)/include
+psxftw01_LDADD = $(RTEMS_ROOT)cpukit/librtemscpu.a $(RTEMS_ROOT)cpukit/libz.a $(LDADD)
+psxftw01-tar.c: psxftw01/psxftw01.tar
+ $(AM_V_GEN)$(BIN2C) -C $< $@
+psxftw01-tar.h: psxftw01/psxftw01.tar
+ $(AM_V_GEN)$(BIN2C) -H $< $@
+psxftw01-tar.o: psxftw01-tar.c psxftw01-tar.h
+psxftw01.tar.gz: psxftw01/psxftw01.tar
+ $(AM_V_GEN)$(GZIP) < $< > $@
+psxftw01-tar-gz.c: psxftw01.tar.gz
+ $(AM_V_GEN)$(BIN2C) -C $< $@
+psxftw01-tar-gz.h: psxftw01.tar.gz
+ $(AM_V_GEN)$(BIN2C) -H $< $@
+CLEANFILES += psxftw01.tar psxftw01-tar.c psxftw01-tar.h \
+ psxftw01.tar.gz psxftw01-tar-gz.c psxftw01-tar-gz.h
+psxftw01/init.c: psxftw01-tar.h psxftw01-tar-gz.h $(TAR01_XZ_H)
+endif
+
if TEST_psxgetattrnp01
psx_tests += psxgetattrnp01
psx_screens += psxgetattrnp01/psxgetattrnp01.scn