summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-11-28 13:34:34 +0530
committerJoel Sherrill <joel@rtems.org>2018-11-28 10:59:24 -0600
commit93ccf479e2621109b4711f0cd4568d2463ae6b68 (patch)
treea6b6eb7ef474853ccd100d121113f82212c83e58 /testsuites/psxtests/Makefile.am
parentlm3s3749-testsuite.tcfg: Add dl07 (diff)
downloadrtems-93ccf479e2621109b4711f0cd4568d2463ae6b68.tar.bz2
psxtests: add POSIX API signature compliance tests for mqueue.h file (GCI 2018)
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index bf1befd337..2385ec8c26 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1093,7 +1093,17 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/dirent/rewinddir.c \
psxhdrs/dirent/scandir.c \
psxhdrs/dirent/seekdir.c \
- psxhdrs/dirent/telldir.c
+ psxhdrs/dirent/telldir.c \
+ psxhdrs/mqueue/mq_open.c \
+ psxhdrs/mqueue/mq_close.c \
+ psxhdrs/mqueue/mq_getattr.c \
+ psxhdrs/mqueue/mq_setattr.c \
+ psxhdrs/mqueue/mq_notify.c \
+ psxhdrs/mqueue/mq_receive.c \
+ psxhdrs/mqueue/mq_send.c \
+ psxhdrs/mqueue/mq_timedreceive.c \
+ psxhdrs/mqueue/mq_timedsend.c \
+ psxhdrs/mqueue/mq_unlink.c
endif
rtems_tests_PROGRAMS = $(psx_tests)