summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJacob Shin <jacobshin313@gmail.com>2018-12-09 19:05:54 -0500
committerJoel Sherrill <joel@rtems.org>2018-12-10 11:50:32 -0600
commit9084b6b53faeaa442b870b6dbb966cf58c63a501 (patch)
treed5059cc9fa2504fceb4139432fd79958d6f2e7a3 /testsuites/psxtests/Makefile.am
parentpsxhdrs: Implement POSIX API Signature Compliance Tests for sys/times.h (GCI ... (diff)
downloadrtems-9084b6b53faeaa442b870b6dbb966cf58c63a501.tar.bz2
psxhdrs: Add POSIX API Signature Compliance Tests for sys/resource.h (GCI 2018)
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index e854c52591..3c5016d567 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1797,7 +1797,8 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/stdlib/unsetenv.c \
psxhdrs/stdlib/wcstombs.c \
psxhdrs/stdlib/wctomb.c \
- psxhdrs/sys/times/times.c
+ psxhdrs/sys/times/times.c \
+ psxhdrs/sys/resource/getrusage.c
## Not supported by RTEMS, but POSIX API Compliance tests exist.
## lib_a_SOURCES += psxhdrs/ulimit/ulimit.c
@@ -1840,6 +1841,10 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
## lib_a_SOURCES += psxhdrs/stdlib/ptsname.c See ticket #3647
## lib_a_SOURCES += psxhdrs/stdlib/unlockpt.c See ticket #3648
## lib_a_SOURCES += psxhdrs/sys/ftok.c See ticket #3650
+## lib_a_SOURCES += psxhdrs/sys/resource/getpriority.c See ticket #3652
+## lib_a_SOURCES += psxhdrs/sys/resource/getrlimit.c See ticket #3653
+## lib_a_SOURCES += psxhdrs/sys/resource/setpriority.c See ticket #3654
+## lib_a_SOURCES += psxhdrs/sys/resource/setrlimit.c See ticket #3655
endif
rtems_tests_PROGRAMS = $(psx_tests)