summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-23 20:30:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-23 20:30:01 +0000
commit6ffde61c4c5ca585d74fbf2a70e5770bd6226161 (patch)
treed4f062b8edb2e3f4dc98d3279c7e5844c15afcbb /testsuites/psxtests/Makefile.am
parent2009-07-23 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-6ffde61c4c5ca585d74fbf2a70e5770bd6226161.tar.bz2
2009-07-23 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add test to exercise interrupt synchronization logic in _POSIX_Timer_Insert_helper that supports POSIX timers. * psxintrcritical01/.cvsignore, psxintrcritical01/Makefile.am, psxintrcritical01/init.c, psxintrcritical01/psxintrcritical01.doc, psxintrcritical01/psxintrcritical01.scn: New files.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 6e963705de..e30bf26201 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -6,10 +6,12 @@ ACLOCAL_AMFLAGS = -I ../aclocal
SUBDIRS = psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psx10 psx11 psx12 psx13 psx14 psxautoinit01 psxautoinit02 psxbarrier01 \
- psxcancel psxcleanup psxcond01 psxenosys psxfatal01 psxfatal02 psxkey01 \
- psxitimer psxmsgq01 psxmsgq02 psxmsgq03 psxmutexattr01 psxobj01 \
- psxrwlock01 psxsem01 psxsignal01 psxspin01 psxspin02 psxsysconf \
- psxtime psxtimer01 psxtimer02 psxualarm
+ psxcancel psxcleanup psxcond01 psxenosys psxkey01 psxitimer psxmsgq01 \
+ psxmsgq02 psxmsgq03 psxmutexattr01 psxobj01 psxrwlock01 psxsem01 \
+ psxsignal01 psxspin01 psxspin02 psxsysconf psxtime psxtimer01 \
+ psxtimer02 psxualarm \
+ psxfatal01 psxfatal02 \
+ psxintrcritical01
## File IO tests
SUBDIRS += psxfile01 psxreaddir psxstat psxmount psx13 psxchroot01