summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorVaibhav Gupta <vaibhavgupta40@gmail.com>2019-07-23 19:11:54 +0530
committerJoel Sherrill <joel@rtems.org>2019-07-30 10:18:09 -0500
commit57e0173584a914b1a92aa73deade6afb463186db (patch)
tree1fe51973e29e9447fd929c565b2288e5a12b18d8 /testsuites/psxtests/Makefile.am
parentarm/raspberrypi: Fix linker map (diff)
downloadrtems-57e0173584a914b1a92aa73deade6afb463186db.tar.bz2
psxtests: Add ndbm test suite
Joel Sherrill <joel@rtems.org> modified the patch to add autoconf logic to avoid building this new test unless the tool chain include <ndbm.h>. The ensures that git bisect continues to work and that the addition of this test does not immediately force the entire community to update their tools.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rwxr-xr-xtestsuites/psxtests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 59c9f2085b..c12b03636d 100755
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -694,6 +694,17 @@ psxmutexattr01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxmutexattr01) \
$(support_includes) -I$(top_srcdir)/include
endif
+if HAS_NDBM
+if TEST_psxndbm01
+psx_tests += psxndbm01
+psx_screens += psxndbm01/psxndbm01.scn
+psx_docs += psxndbm01/psxndbm01.doc
+psxndbm01_SOURCES = psxndbm01/init.c
+psxndbm01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxndbm01) \
+ $(support_includes)
+endif
+endif
+
if TEST_psxobj01
psx_tests += psxobj01
psx_screens += psxobj01/psxobj01.scn