summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-24 21:34:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-24 21:34:47 +0000
commit41f17ba4a5e603ae5360962ac9f9fda9064f554a (patch)
tree7be92d93b0b8bc3014959ed7aec1652c1fef59b2 /testsuites/psxtests/Makefile.am
parentRemove C++ comment. (diff)
downloadrtems-41f17ba4a5e603ae5360962ac9f9fda9064f554a.tar.bz2
2007-09-24 Joel Sherrill <joel.sherrill@oarcorp.com>
PR 1262/filesystem * Makefile.am, configure.ac, include/pmacros.h: Add support for readv() and writev() including documentation and test case. * psxrdwrv/.cvsignore, psxrdwrv/Makefile.am, psxrdwrv/main.c, psxrdwrv/psxrdwrv.scn, psxrdwrv/test.c: New files.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 418b40870f..119004434d 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -8,7 +8,16 @@ SUBDIRS = psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psx10 psx11 psx12 psxtime psxtimer psxcancel psxbarrier01 psxmsgq01 \
psxrwlock01 psxsem01 psxspin01
+## File IO tests
SUBDIRS += psxfile01 psxreaddir psxstat psxmount psx13 psxchroot01
+## Until sys/uio.h is moved to libcsupport, we have to have networking
+## enabled to support readv and writev. Hopefully this is a temporary
+## situation.
+if HAS_NETWORKING
+SUBDIRS += psxrdwrv
+endif
+
+
include $(top_srcdir)/../automake/subdirs.am
include $(top_srcdir)/../automake/local.am