summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-11-27 22:40:30 +0530
committerJoel Sherrill <joel@rtems.org>2018-11-27 11:25:38 -0600
commit27a8fc56ee036c5e8f0303ef35dde1f3b0fb755b (patch)
treef3616f4aef7e28aea1e7ad0d6b0f189802cd23c4 /testsuites/psxtests/Makefile.am
parentm68k/av5282: Add per-section compilation and linking support (GCI 2018) (diff)
downloadrtems-27a8fc56ee036c5e8f0303ef35dde1f3b0fb755b.tar.bz2
psxtests: add POSIX API signature compliance tests for dirent.h file (GCI 2018)
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 2a32436be4..bf1befd337 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1082,7 +1082,18 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/sys/socket/send.c psxhdrs/sys/socket/sendmsg.c \
psxhdrs/sys/socket/sendto.c psxhdrs/sys/socket/setsockopt.c \
psxhdrs/sys/socket/shutdown.c psxhdrs/sys/socket/socket.c \
- psxhdrs/sys/socket/socketpair.c
+ psxhdrs/sys/socket/socketpair.c \
+ psxhdrs/dirent/alphasort.c \
+ psxhdrs/dirent/closedir.c \
+ psxhdrs/dirent/dirfd.c \
+ psxhdrs/dirent/fdopendir.c \
+ psxhdrs/dirent/opendir.c \
+ psxhdrs/dirent/readdir.c \
+ psxhdrs/dirent/readdir_r.c \
+ psxhdrs/dirent/rewinddir.c \
+ psxhdrs/dirent/scandir.c \
+ psxhdrs/dirent/seekdir.c \
+ psxhdrs/dirent/telldir.c
endif
rtems_tests_PROGRAMS = $(psx_tests)