summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorShashvat Jain <shashvatjain2002@gmail.com>2018-12-06 13:24:13 -0500
committerJoel Sherrill <joel@rtems.org>2018-12-06 13:08:33 -0600
commit1e455d417475904f2d6752f130700d6c336a25da (patch)
tree9a1a74cab13847b081d451c5f7faa237d903c0cd /testsuites/psxtests/Makefile.am
parentpsxhdrs: Add POSIX API Signature Compliance Tests for string.h (GCI 2018) (diff)
downloadrtems-1e455d417475904f2d6752f130700d6c336a25da.tar.bz2
psxhdrs:Add POSIX Conformance Test for fmtmsg.h (GCI 2018)
Includes test fmtmsg which has been disabled due to the absence of header file fmtmsg.h . Updates #3639
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 526a500eb7..5132628e04 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1573,7 +1573,8 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/wctype/wctrans.c \
psxhdrs/wctype/wctrans_l.c \
psxhdrs/wctype/wctype.c \
- psxhdrs/wctype/wctype_l.c
+ psxhdrs/wctype/wctype_l.c \
+ psxhdrs/fmtmsg/fmtmsg.c
## Not supported by RTEMS, but POSIX API Compliance tests exist.
## lib_a_SOURCES += psxhdrs/ulimit/ulimit.c
@@ -1600,6 +1601,7 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
## lib_a_SOURCES += psxhdrs/ftw/nftw.c See ticket #2970
## lib_a_SOURCES += psxhdrs/stdio/getdelim.c See ticket #3633
## lib_a_SOURCES += psxhdrs/stdio/getline.c See ticket #3633
+## lib_a_SOURCES += psxhdrs/fmtmsg/fmtmsg.c See ticket #3639
endif
rtems_tests_PROGRAMS = $(psx_tests)