summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-20 01:12:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-20 01:12:25 +0000
commit1938cc07dfb66d4192083ad0c91a9ae57c3b4a6c (patch)
treee65f002c53708aa203ef85c140eb5f5bacee9aef /testsuites/psxtests/Makefile.am
parent2009-07-19 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-1938cc07dfb66d4192083ad0c91a9ae57c3b4a6c.tar.bz2
2009-07-19 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add psxspin02 to exercise case where trylock is unable to obtain the spinlock and that attempting to unlock a spinlock from a thread which did not lock it works as expected. * psxspin02/.cvsignore, psxspin02/Makefile.am, psxspin02/main.c, psxspin02/psxspin02.doc, psxspin02/psxspin02.scn, psxspin02/test.c: New files.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 2c94e8e264..3e93499b3d 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -8,8 +8,8 @@ SUBDIRS = psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psx10 psx11 psx12 psx13 psx14 psxautoinit01 psxautoinit02 psxbarrier01 \
psxcancel psxcleanup psxenosys psxfatal01 psxfatal02 psxkey01 psxitimer \
psxmsgq01 psxmsgq02 psxmsgq03 psxmutexattr01 psxobj01 psxrwlock01 \
- psxsem01 psxsignal01 psxspin01 psxsysconf psxtime psxtimer01 psxtimer02 \
- psxualarm
+ psxsem01 psxsignal01 psxspin01 psxspin02 psxsysconf psxtime psxtimer01 \
+ psxtimer02 psxualarm
## File IO tests
SUBDIRS += psxfile01 psxreaddir psxstat psxmount psx13 psxchroot01