summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2014-05-05 08:12:52 +1000
committerChris Johns <chrisj@rtems.org>2014-05-05 10:24:41 +1000
commit1461b648b7fc53b903c07da49df1bf24d96e8dca (patch)
treefd5016bd1a13b7d19cf3cbb93a6c084a69e92835 /testsuites/psxtests/Makefile.am
parentlibchip: Add asserts to dwmac driver (diff)
downloadrtems-1461b648b7fc53b903c07da49df1bf24d96e8dca.tar.bz2
testsuite: Add a per BSP test check for tests not to build.
Provide a file per BSP to list tests that do not build for a BSP. This change removes the BSP_SMALL_MEMORY hack from the code. That hack was a mistake. Provide configuration files for each BSP with tests that cannot build.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 172599bab9..d8eee14a7e 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1,8 +1,8 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-SUBDIRS = psxclock
+_SUBDIRS = psxclock
if HAS_POSIX
-SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
+_SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
psx10 psx11 psx12 psx13 psx14 psx15 psx16 \
psxaio01 psxaio02 psxaio03 \
psxalarm01 psxautoinit01 psxautoinit02 psxbarrier01 \
@@ -18,22 +18,22 @@ SUBDIRS += psxhdrs psx01 psx02 psx03 psx04 psx05 psx06 psx07 psx08 psx09 \
endif
## File IO tests
-SUBDIRS += psxfile01 psxfile02 psxfilelock01 psxgetrusage01 psxid01 \
+_SUBDIRS += psxfile01 psxfile02 psxfilelock01 psxgetrusage01 psxid01 \
psximfs01 psximfs02 psxreaddir psxstat psxmount psx13 psxchroot01 \
psxpasswd01 psxpasswd02 psxpipe01 psxtimes01 psxfchx01
## POSIX Keys are always available
-SUBDIRS += psxkey01 psxkey02 psxkey03 psxkey04 \
+_SUBDIRS += psxkey01 psxkey02 psxkey03 psxkey04 \
psxkey05 psxkey06 psxkey08 psxkey09 psxkey10
## But some of the tests need other POSIX features
if HAS_POSIX
-SUBDIRS += psxkey07
+_SUBDIRS += psxkey07
endif
## POSIX Once is always available
-SUBDIRS += psxonce01
+_SUBDIRS += psxonce01
-SUBDIRS += psxrdwrv
+_SUBDIRS += psxrdwrv
-include $(top_srcdir)/../automake/subdirs.am
+include $(top_srcdir)/../automake/test-subdirs.am
include $(top_srcdir)/../automake/local.am