summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-12-02 16:31:18 +0530
committerJoel Sherrill <joel@rtems.org>2018-12-02 08:48:12 -0600
commit0888bfd5dd50e45c3e89c3944f2bdb703ee889df (patch)
tree32ea448a740137fc882c09a0bab765a6b584dbd1 /testsuites/psxtests/Makefile.am
parentpsxhdrs: add POSIX API Signature Compliance Tests for dlfcn.h File (GCI 2018) (diff)
downloadrtems-0888bfd5dd50e45c3e89c3944f2bdb703ee889df.tar.bz2
psxhdrs: add POSIX API Signature Compliance Tests for locale.h (GCI 2018)
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 692182854e..3d076b0a27 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1126,7 +1126,13 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/dlfcn/dlopen.c \
psxhdrs/dlfcn/dlclose.c \
psxhdrs/dlfcn/dlerror.c \
- psxhdrs/dlfcn/dlsym.c
+ psxhdrs/dlfcn/dlsym.c \
+ psxhdrs/locale/newlocale.c \
+ psxhdrs/locale/freelocale.c \
+ psxhdrs/locale/uselocale.c \
+ psxhdrs/locale/setlocale.c \
+ psxhdrs/locale/duplocale.c \
+ psxhdrs/locale/localeconv.c
endif
rtems_tests_PROGRAMS = $(psx_tests)