summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/termios05/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-01 14:35:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-07-01 14:35:00 +0000
commit7424c3ee866ba2a468d7959c4993f83e8667e7a0 (patch)
treec06da1c7abadce221ed963092384055d4ad3b037 /testsuites/libtests/termios05/Makefile.am
parent2010-07-01 Sebastian Huber <sebastian.huber@embedded-brains.de> (diff)
downloadrtems-7424c3ee866ba2a468d7959c4993f83e8667e7a0.tar.bz2
2010-07-01 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add test for task driven drivers. * termios05/.cvsignore, termios05/Makefile.am, termios05/init.c, termios05/termios05.doc, termios05/termios05.scn, termios05/termios_testdriver_taskdriven.c, termios05/termios_testdriver_taskdriven.h: New files.
Diffstat (limited to 'testsuites/libtests/termios05/Makefile.am')
-rw-r--r--testsuites/libtests/termios05/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/libtests/termios05/Makefile.am b/testsuites/libtests/termios05/Makefile.am
new file mode 100644
index 0000000000..1ac6602633
--- /dev/null
+++ b/testsuites/libtests/termios05/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = termios05
+termios05_SOURCES = init.c ../termios04/termios_testdriver_intr.c
+
+dist_rtems_tests_DATA = termios05.scn
+dist_rtems_tests_DATA += termios05.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -I$(top_srcdir)/termios04
+AM_CPPFLAGS += -DTASK_DRIVEN
+
+LINK_OBJS = $(termios05_OBJECTS) $(termios05_LDADD)
+LINK_LIBS = $(termios05_LDLIBS)
+
+termios05$(EXEEXT): $(termios05_OBJECTS) $(termios05_DEPENDENCIES)
+ @rm -f termios05$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am