summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/tar01/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-08-01 11:02:13 +1000
committerChris Johns <chrisj@rtems.org>2016-08-09 17:22:26 +1000
commitb0f08c83e23e69c7b19b04d38910f90b5f7af51b (patch)
tree260e3b5eb5323bcd5628d3269dcd96207f02ee4c /testsuites/libtests/tar01/Makefile.am
parentbsp/atsam: Add power support (diff)
downloadrtems-b0f08c83e23e69c7b19b04d38910f90b5f7af51b.tar.bz2
libmisc/untar: Set the perms to the value in the tar file.
This patch parses the mode field in the tar header and sets the directory or file to the mode value in the header. Closes #2768.
Diffstat (limited to 'testsuites/libtests/tar01/Makefile.am')
-rw-r--r--testsuites/libtests/tar01/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/testsuites/libtests/tar01/Makefile.am b/testsuites/libtests/tar01/Makefile.am
index d7257bc69f..8b03e59c2d 100644
--- a/testsuites/libtests/tar01/Makefile.am
+++ b/testsuites/libtests/tar01/Makefile.am
@@ -9,7 +9,7 @@ tar01_SOURCES += initial_filesystem_tar_gz.c
tar01_SOURCES += initial_filesystem_tar_gz.h
tar01_LDADD = -lrtemscpu -lz
-
+
BUILT_SOURCES =
BUILT_SOURCES += initial_filesystem_tar.c
BUILT_SOURCES += initial_filesystem_tar.h
@@ -57,6 +57,9 @@ initial_filesystem.tar:
$(MKDIR_P) initial_fs/home
(echo "This is a test of loading an RTEMS filesystem from an" ; \
echo "initial tar image.") >initial_fs/home/test_file
+ (echo "#! joel" ; \
+ echo "ls -las /dev") >initial_fs/home/test_script
+ chmod +x initial_fs/home/test_script
(cd initial_fs; \
$(LN_S) home/test_file symlink; \
$(PAX) -w -f ../initial_filesystem.tar home symlink)