summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/pwdgrp02/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-17 13:35:58 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-20 10:30:24 +0100
commite02d5dd9b3143b2e72d2c71e914d7bd96a47bf7b (patch)
treec7f966aea6a8d1ef261010f7b12c6e838075a619 /testsuites/libtests/pwdgrp02/Makefile.am
parentshell: Do chroot() after successful login (diff)
downloadrtems-e02d5dd9b3143b2e72d2c71e914d7bd96a47bf7b.tar.bz2
Ensure security of default user environment
Diffstat (limited to 'testsuites/libtests/pwdgrp02/Makefile.am')
-rw-r--r--testsuites/libtests/pwdgrp02/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/testsuites/libtests/pwdgrp02/Makefile.am b/testsuites/libtests/pwdgrp02/Makefile.am
new file mode 100644
index 0000000000..10ce651367
--- /dev/null
+++ b/testsuites/libtests/pwdgrp02/Makefile.am
@@ -0,0 +1,19 @@
+rtems_tests_PROGRAMS = pwdgrp02
+pwdgrp02_SOURCES = init.c
+
+dist_rtems_tests_DATA = pwdgrp02.scn pwdgrp02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(pwdgrp02_OBJECTS)
+LINK_LIBS = $(pwdgrp02_LDLIBS)
+
+pwdgrp02$(EXEEXT): $(pwdgrp02_OBJECTS) $(pwdgrp02_DEPENDENCIES)
+ @rm -f pwdgrp02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am