summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/mathf/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsépius <ralf.corsepius@rtems.org>2012-05-23 16:45:01 +0200
committerJoel Sherrill <joel.sherrill@oarcorp.com>2012-05-31 10:06:14 -0500
commit5e707bc75ebe7e481ec8a4920cab865d465c254a (patch)
treeb391a66749ac6e3c76078277fc54dbaddca59ab2 /testsuites/libtests/mathf/Makefile.am
parentRevert "libtests/complex: Avoid generated files" (diff)
downloadrtems-5e707bc75ebe7e481ec8a4920cab865d465c254a.tar.bz2
Revert "libtests/math*: Avoid generated files"
This reverts commit 6a5bd1c65c005457455db344f2ee831d7a5cf99b.
Diffstat (limited to 'testsuites/libtests/mathf/Makefile.am')
-rw-r--r--testsuites/libtests/mathf/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/testsuites/libtests/mathf/Makefile.am b/testsuites/libtests/mathf/Makefile.am
index e4bd7ba10c..0834145292 100644
--- a/testsuites/libtests/mathf/Makefile.am
+++ b/testsuites/libtests/mathf/Makefile.am
@@ -1,5 +1,12 @@
rtems_tests_PROGRAMS = mathf
mathf_SOURCES = init.c domathf.c
+EXTRA_DIST = $(srcdir)/../math/domath.in
+
+$(srcdir)/domathf.c: $(srcdir)/../math/domath.in
+ sed -e 's,[@]FTYPE[@],float,' \
+ -e 's,[@]FSUFFIX[@],f,g' \
+ -e 's,[@]FGUARD[@],NO_FLOAT,' \
+ $(srcdir)/../math/domath.in > $(srcdir)/domathf.c
dist_rtems_tests_DATA = mathf.scn
@@ -7,7 +14,6 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-mathf_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/math
mathf_LDADD = -lm
LINK_OBJS = $(mathf_OBJECTS) $(mathf_LDADD)