summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/mathf/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2011-02-02 13:58:02 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2011-02-02 13:58:02 +0000
commit2e50ba1a2ba837522ce0aa41899011c30fbc2a8e (patch)
tree04ee6f09527c9955a2c2cb4fea48d410b9f9b9fe /testsuites/libtests/mathf/Makefile.am
parent2011-02-02 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-2e50ba1a2ba837522ce0aa41899011c30fbc2a8e.tar.bz2
New (Split out from math/).
Diffstat (limited to 'testsuites/libtests/mathf/Makefile.am')
-rw-r--r--testsuites/libtests/mathf/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/libtests/mathf/Makefile.am b/testsuites/libtests/mathf/Makefile.am
new file mode 100644
index 0000000000..57b372e08f
--- /dev/null
+++ b/testsuites/libtests/mathf/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+rtems_tests_PROGRAMS = mathf
+mathf_SOURCES = init.c domathf.c
+EXTRA_DIST = $(srcdir)/../math/domath.in
+
+$(srcdir)/domathf.c: $(srcdir)/../math/domath.in
+ sed -e 's,[@]FTYPE[@],float,' \
+ -e 's,[@]FSUFFIX[@],f,g' \
+ -e 's,[@]FGUARD[@],NO_FLOAT,' \
+ $(srcdir)/../math/domath.in > $(srcdir)/domathf.c
+
+dist_rtems_tests_DATA = mathf.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+mathf_LDADD = -lm
+
+LINK_OBJS = $(mathf_OBJECTS) $(mathf_LDADD)
+LINK_LIBS = $(mathf_LDLIBS)
+
+mathf$(EXEEXT): $(mathf_OBJECTS) $(mathf_DEPENDENCIES)
+ @rm -f mathf$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am