summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/mathf/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsépius <ralf.corsepius@rtems.org>2012-05-24 07:15:40 +0200
committerRalf Corsépius <ralf.corsepius@rtems.org>2012-05-24 07:15:40 +0200
commit1831fd1272a352bf27d2e68cf040a8700fb8d78a (patch)
tree24fdd70d1f03ea12d6f572a05b85fa049c59365b /testsuites/libtests/mathf/Makefile.am
parentRevert "libtests/math*: Avoid generated files" (diff)
downloadrtems-1831fd1272a352bf27d2e68cf040a8700fb8d78a.tar.bz2
Revert "Revert "libtests/math*: Avoid generated files""
This reverts commit 87c8d8aba6a9582ca5eeacd332b5b107e26ea50f.
Diffstat (limited to 'testsuites/libtests/mathf/Makefile.am')
-rw-r--r--testsuites/libtests/mathf/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/testsuites/libtests/mathf/Makefile.am b/testsuites/libtests/mathf/Makefile.am
index 0834145292..e4bd7ba10c 100644
--- a/testsuites/libtests/mathf/Makefile.am
+++ b/testsuites/libtests/mathf/Makefile.am
@@ -1,12 +1,5 @@
rtems_tests_PROGRAMS = mathf
mathf_SOURCES = init.c domathf.c
-EXTRA_DIST = $(srcdir)/../math/domath.in
-
-$(srcdir)/domathf.c: $(srcdir)/../math/domath.in
- sed -e 's,[@]FTYPE[@],float,' \
- -e 's,[@]FSUFFIX[@],f,g' \
- -e 's,[@]FGUARD[@],NO_FLOAT,' \
- $(srcdir)/../math/domath.in > $(srcdir)/domathf.c
dist_rtems_tests_DATA = mathf.scn
@@ -14,6 +7,7 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
+mathf_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/math
mathf_LDADD = -lm
LINK_OBJS = $(mathf_OBJECTS) $(mathf_LDADD)