summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/heapwalk/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-05-07 17:48:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-05-07 17:48:15 +0000
commit56b7951e4563580d96b5d2249e2d3e3d62d48120 (patch)
tree363896937fe539f082bbc0a5d891e9e295ff8d1f /testsuites/libtests/heapwalk/Makefile.am
parent2009-05-07 Santosh G Vattam <vattam.santosh@gmail.com> (diff)
downloadrtems-56b7951e4563580d96b5d2249e2d3e3d62d48120.tar.bz2
2009-05-07 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add shell of heap walk test for Santosh. * heapwalk/.cvsignore, heapwalk/Makefile.am, heapwalk/heapwalk.scn, heapwalk/init.c, heapwalk/system.h: New files.
Diffstat (limited to 'testsuites/libtests/heapwalk/Makefile.am')
-rw-r--r--testsuites/libtests/heapwalk/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/libtests/heapwalk/Makefile.am b/testsuites/libtests/heapwalk/Makefile.am
new file mode 100644
index 0000000000..46b972da00
--- /dev/null
+++ b/testsuites/libtests/heapwalk/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = heapwalk
+heapwalk_SOURCES = init.c system.h
+
+dist_rtems_tests_DATA = heapwalk.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+heapwalk_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(heapwalk_OBJECTS) $(heapwalk_LDADD)
+LINK_LIBS = $(heapwalk_LDLIBS)
+
+heapwalk$(EXEEXT): $(heapwalk_OBJECTS) $(heapwalk_DEPENDENCIES)
+ @rm -f heapwalk$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am