summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2012-10-03 11:09:32 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2012-10-03 11:09:32 -0500
commitcb7b57e174d7a559af3ec910a99e0538cc9f99b7 (patch)
treec9e52f936e1b9560fbd104c6f75743ead4e1a4d6 /testsuites/libtests/configure.ac
parentthreaddispatch.c: Fix typo (diff)
downloadrtems-cb7b57e174d7a559af3ec910a99e0538cc9f99b7.tar.bz2
mghttpd: Requires POSIX to build server and tests
Formerly, mghttpd was conditional only on networking being enabled. It uses on pthread and must also be conditional on POSIX threads support being enabled.
Diffstat (limited to 'testsuites/libtests/configure.ac')
-rw-r--r--testsuites/libtests/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/testsuites/libtests/configure.ac b/testsuites/libtests/configure.ac
index a29c7f8a4e..b40055c6ec 100644
--- a/testsuites/libtests/configure.ac
+++ b/testsuites/libtests/configure.ac
@@ -27,6 +27,7 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_CXX(RTEMS_BSP)
RTEMS_CHECK_CPUOPTS([RTEMS_NETWORKING])
+RTEMS_CHECK_CPUOPTS([RTEMS_POSIX_API])
AC_PROG_LN_S
AC_PATH_PROG([PAX],[pax])
@@ -38,6 +39,7 @@ AM_CONDITIONAL(TARTESTS,test "$as_ln_s" = "ln -s" && test -n "$PAX")
AM_CONDITIONAL(HAS_CXX,test "$rtems_cv_HAS_CPLUSPLUS" = "yes")
AM_CONDITIONAL([HAS_COMPLEX],[test "$ac_cv_header_complex_h" = yes])
AM_CONDITIONAL(NETTESTS,test "$rtems_cv_RTEMS_NETWORKING" = "yes")
+AM_CONDITIONAL(HAS_POSIX,test x"${rtems_cv_RTEMS_POSIX_API}" = x"yes")
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile