summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-11-25 15:13:36 +1100
committerChris Johns <chrisj@rtems.org>2016-11-29 08:50:40 +1100
commita0d4e9933c57693f99203da358bb8aaa8a5d50d9 (patch)
treed17a98faf93185d2baa18fba6ee97b0e2916b2e4 /testsuites/libtests/configure.ac
parentarm/zynq: Wait for the UART TX FIFO to empty on reset. (diff)
downloadrtems-a0d4e9933c57693f99203da358bb8aaa8a5d50d9.tar.bz2
cpukit: Add libdebugger, a remote debugger agent for GDB.
Diffstat (limited to 'testsuites/libtests/configure.ac')
-rw-r--r--testsuites/libtests/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/testsuites/libtests/configure.ac b/testsuites/libtests/configure.ac
index 430c509640..8e74b3e979 100644
--- a/testsuites/libtests/configure.ac
+++ b/testsuites/libtests/configure.ac
@@ -80,6 +80,17 @@ AS_IF([test x"$TEST_LIBDL" = x"yes"],[
AM_CONDITIONAL(DLTESTS,[test x"$TEST_LIBDL" = x"yes"])
+# Must match the list in cpukit.
+AC_MSG_CHECKING([whether CPU supports libdebugger])
+case $RTEMS_CPU in
+ arm | i386)
+ TEST_LIBDEBUGGER=yes ;;
+ *)
+ TEST_LIBDEBUGGER=no ;;
+esac
+AC_MSG_RESULT([$TEST_LIBDEBUGGER])
+AM_CONDITIONAL(DEBUGGERTESTS,[test x"$TEST_LIBDEBUGGER" = x"yes"])
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
networking01/Makefile
@@ -169,5 +180,6 @@ math/Makefile
mathf/Makefile
mathl/Makefile
complex/Makefile
+debugger01/Makefile
])
AC_OUTPUT