summaryrefslogtreecommitdiffstats
path: root/testsuites/libtests/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2018-04-09 13:39:19 +1000
committerChris Johns <chrisj@rtems.org>2018-04-10 08:24:54 +1000
commit5c65b9881bec47e322607a9a63c83d1a229c1710 (patch)
tree18201091467d737156766d37d3608279a756f7b6 /testsuites/libtests/configure.ac
parenttestsuite/benchmarks: Merged nested Makefile.am files into one Makefile.am (diff)
downloadrtems-5c65b9881bec47e322607a9a63c83d1a229c1710.tar.bz2
testsuite/libtests: Merged nested Makefile.am files into one Makefile.am
This change is part of the testsuite Makefile.am reorganization. Update #3382
Diffstat (limited to 'testsuites/libtests/configure.ac')
-rw-r--r--testsuites/libtests/configure.ac231
1 files changed, 138 insertions, 93 deletions
diff --git a/testsuites/libtests/configure.ac b/testsuites/libtests/configure.ac
index dc4602cbb2..253eb7c287 100644
--- a/testsuites/libtests/configure.ac
+++ b/testsuites/libtests/configure.ac
@@ -93,97 +93,142 @@ esac
AC_MSG_RESULT([$TEST_LIBDEBUGGER])
AM_CONDITIONAL(DEBUGGERTESTS,[test x"$TEST_LIBDEBUGGER" = x"yes"])
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-POSIX/Makefile
-block01/Makefile
-block02/Makefile
-block03/Makefile
-block04/Makefile
-block05/Makefile
-block06/Makefile
-block07/Makefile
-block08/Makefile
-block09/Makefile
-block10/Makefile
-block11/Makefile
-block12/Makefile
-block13/Makefile
-block14/Makefile
-block15/Makefile
-block16/Makefile
-block17/Makefile
-bspcmdline01/Makefile
-capture01/Makefile
-complex/Makefile
-cpuuse/Makefile
-crypt01/Makefile
-debugger01/Makefile
-defaultconfig01/Makefile
-devfs01/Makefile
-devfs02/Makefile
-devfs03/Makefile
-devfs04/Makefile
-deviceio01/Makefile
-devnullfatal01/Makefile
-dl01/Makefile
-dl02/Makefile
-dl03/Makefile
-dl04/Makefile
-dl05/Makefile
-dumpbuf01/Makefile
-exit01/Makefile
-exit02/Makefile
-flashdisk01/Makefile
-ftp01/Makefile
-gxx01/Makefile
-heapwalk/Makefile
-i2c01/Makefile
-libfdt01/Makefile
-malloc02/Makefile
-malloc03/Makefile
-malloc04/Makefile
-malloctest/Makefile
-math/Makefile
-mathf/Makefile
-mathl/Makefile
-md501/Makefile
-mghttpd01/Makefile
-monitor/Makefile
-monitor02/Makefile
-mouse01/Makefile
-networking01/Makefile
-newlib01/Makefile
-putenvtest/Makefile
-pwdgrp01/Makefile
-pwdgrp02/Makefile
-getentropy01/Makefile
-rbheap01/Makefile
-rtmonuse/Makefile
-sha/Makefile
-shell01/Makefile
-sparsedisk01/Makefile
-spi01/Makefile
-stackchk/Makefile
-stackchk01/Makefile
-stringto01/Makefile
-syscall01/Makefile
-tar01/Makefile
-tar02/Makefile
-tar03/Makefile
-termios/Makefile
-termios01/Makefile
-termios02/Makefile
-termios03/Makefile
-termios04/Makefile
-termios05/Makefile
-termios06/Makefile
-termios07/Makefile
-termios08/Makefile
-termios09/Makefile
-top/Makefile
-tztest/Makefile
-uid01/Makefile
-utf8proc01/Makefile
-])
+# BSP Test configuration
+RTEMS_TEST_CHECK([block01])
+RTEMS_TEST_CHECK([block02])
+RTEMS_TEST_CHECK([block03])
+RTEMS_TEST_CHECK([block04])
+RTEMS_TEST_CHECK([block05])
+RTEMS_TEST_CHECK([block06])
+RTEMS_TEST_CHECK([block07])
+RTEMS_TEST_CHECK([block08])
+RTEMS_TEST_CHECK([block09])
+RTEMS_TEST_CHECK([block10])
+RTEMS_TEST_CHECK([block11])
+RTEMS_TEST_CHECK([block12])
+RTEMS_TEST_CHECK([block13])
+RTEMS_TEST_CHECK([block14])
+RTEMS_TEST_CHECK([block15])
+RTEMS_TEST_CHECK([block16])
+RTEMS_TEST_CHECK([block17])
+RTEMS_TEST_CHECK([bspcmdline01])
+RTEMS_TEST_CHECK([calloc])
+RTEMS_TEST_CHECK([capture01])
+RTEMS_TEST_CHECK([clock_gettime])
+RTEMS_TEST_CHECK([close])
+RTEMS_TEST_CHECK([complex])
+RTEMS_TEST_CHECK([cpuuse])
+RTEMS_TEST_CHECK([crypt01])
+RTEMS_TEST_CHECK([debugger01])
+RTEMS_TEST_CHECK([defaultconfig01])
+RTEMS_TEST_CHECK([devfs01])
+RTEMS_TEST_CHECK([devfs02])
+RTEMS_TEST_CHECK([devfs03])
+RTEMS_TEST_CHECK([devfs04])
+RTEMS_TEST_CHECK([deviceio01])
+RTEMS_TEST_CHECK([devnullfatal01])
+RTEMS_TEST_CHECK([dl01])
+RTEMS_TEST_CHECK([dl02])
+RTEMS_TEST_CHECK([dl03])
+RTEMS_TEST_CHECK([dl04])
+RTEMS_TEST_CHECK([dl05])
+RTEMS_TEST_CHECK([dumpbuf01])
+RTEMS_TEST_CHECK([dup2])
+RTEMS_TEST_CHECK([exit01])
+RTEMS_TEST_CHECK([exit02])
+RTEMS_TEST_CHECK([fcntl])
+RTEMS_TEST_CHECK([flashdisk01])
+RTEMS_TEST_CHECK([flockfile])
+RTEMS_TEST_CHECK([fork])
+RTEMS_TEST_CHECK([free])
+RTEMS_TEST_CHECK([fstat])
+RTEMS_TEST_CHECK([ftp01])
+RTEMS_TEST_CHECK([ftrylockfile])
+RTEMS_TEST_CHECK([funlockfile])
+RTEMS_TEST_CHECK([getentropy01])
+RTEMS_TEST_CHECK([getlogin])
+RTEMS_TEST_CHECK([getpwnam])
+RTEMS_TEST_CHECK([getpwuid])
+RTEMS_TEST_CHECK([gettimeofday])
+RTEMS_TEST_CHECK([getuid])
+RTEMS_TEST_CHECK([gxx01])
+RTEMS_TEST_CHECK([heapwalk])
+RTEMS_TEST_CHECK([htonl])
+RTEMS_TEST_CHECK([i2c01])
+RTEMS_TEST_CHECK([iconv])
+RTEMS_TEST_CHECK([iconv_close])
+RTEMS_TEST_CHECK([iconv_open])
+RTEMS_TEST_CHECK([kill])
+RTEMS_TEST_CHECK([libfdt01])
+RTEMS_TEST_CHECK([longjmp])
+RTEMS_TEST_CHECK([lseek])
+RTEMS_TEST_CHECK([lstat])
+RTEMS_TEST_CHECK([malloc])
+RTEMS_TEST_CHECK([malloc02])
+RTEMS_TEST_CHECK([malloc03])
+RTEMS_TEST_CHECK([malloc04])
+RTEMS_TEST_CHECK([malloctest])
+RTEMS_TEST_CHECK([math])
+RTEMS_TEST_CHECK([mathf])
+RTEMS_TEST_CHECK([mathl])
+RTEMS_TEST_CHECK([md501])
+RTEMS_TEST_CHECK([mghttpd01])
+RTEMS_TEST_CHECK([monitor])
+RTEMS_TEST_CHECK([monitor02])
+RTEMS_TEST_CHECK([mouse01])
+RTEMS_TEST_CHECK([nanosleep])
+RTEMS_TEST_CHECK([networking01])
+RTEMS_TEST_CHECK([newlib01])
+RTEMS_TEST_CHECK([open])
+RTEMS_TEST_CHECK([pipe])
+RTEMS_TEST_CHECK([posix_memalign])
+RTEMS_TEST_CHECK([putenvtest])
+RTEMS_TEST_CHECK([pwdgrp01])
+RTEMS_TEST_CHECK([pwdgrp02])
+RTEMS_TEST_CHECK([rbheap01])
+RTEMS_TEST_CHECK([read])
+RTEMS_TEST_CHECK([readv])
+RTEMS_TEST_CHECK([realloc])
+RTEMS_TEST_CHECK([rtmonuse])
+RTEMS_TEST_CHECK([setjmp])
+RTEMS_TEST_CHECK([sha])
+RTEMS_TEST_CHECK([shell01])
+RTEMS_TEST_CHECK([sigaddset])
+RTEMS_TEST_CHECK([sigdelset])
+RTEMS_TEST_CHECK([sigemptyset])
+RTEMS_TEST_CHECK([sigfillset])
+RTEMS_TEST_CHECK([sigismember])
+RTEMS_TEST_CHECK([sigprocmask])
+RTEMS_TEST_CHECK([sparsedisk01])
+RTEMS_TEST_CHECK([spi01])
+RTEMS_TEST_CHECK([stackchk])
+RTEMS_TEST_CHECK([stackchk01])
+RTEMS_TEST_CHECK([stat])
+RTEMS_TEST_CHECK([stringto01])
+RTEMS_TEST_CHECK([syscall01])
+RTEMS_TEST_CHECK([tar01])
+RTEMS_TEST_CHECK([tar02])
+RTEMS_TEST_CHECK([tar03])
+RTEMS_TEST_CHECK([termios])
+RTEMS_TEST_CHECK([termios01])
+RTEMS_TEST_CHECK([termios02])
+RTEMS_TEST_CHECK([termios03])
+RTEMS_TEST_CHECK([termios04])
+RTEMS_TEST_CHECK([termios05])
+RTEMS_TEST_CHECK([termios06])
+RTEMS_TEST_CHECK([termios07])
+RTEMS_TEST_CHECK([termios08])
+RTEMS_TEST_CHECK([termios09])
+RTEMS_TEST_CHECK([top])
+RTEMS_TEST_CHECK([tztest])
+RTEMS_TEST_CHECK([uid01])
+RTEMS_TEST_CHECK([unlink])
+RTEMS_TEST_CHECK([utf8proc01])
+RTEMS_TEST_CHECK([vfork])
+RTEMS_TEST_CHECK([wait])
+RTEMS_TEST_CHECK([waitpid])
+RTEMS_TEST_CHECK([write])
+RTEMS_TEST_CHECK([writev])
+
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT